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Overview 

Stellar Phoenix Windows Backup Recovery recovers data from the corrupt backup files. Backup files 

can get corrupted due to the following reasons: 

 Unrecognizable file format 

 Runtime error 

 CRC (Cyclic Redundancy Check) error 

Stellar Phoenix Windows Backup Recovery uses an advanced algorithm to recover data from the 

corrupt backup files. The application is very user friendly and does not require any prior technical skill to 

recover data from the corrupt BKF / ZIP / VHDX files. 

  

What's new in this version? 

 Support for Windows 10. 

 Recovers Microsoft Backup (VHDX) files created using Windows 10 / Windows 8.1 backup 

utilities. 

 Key features of Stellar Phoenix Windows Backup Recovery: 

 Recovers Microsoft Backup (BKF) files created using Windows 2003 / Windows 2000 / Windows 

XP backup utilities. 

 Recovers Microsoft Backup (ZIP) files created using Windows 8 / Windows 7 / Windows Vista 

backup utilities. 

 Recovers Microsoft Backup (VHDX) files created using Windows 10 / Windows 8.1 backup 

utilities. 

 Recovers BKF files created using Backup Exec by SYMANTEC software. 

 Provides rich graphical user interface. 

 Saves a recovered file at either default location or to a location of your choice. 

 Provides search option to find a BKF / ZIP / VHDX file. 

 Allows you to preview the BKF file before saving it. 

 Allows you to preview the VHDX file before saving it. 

 Supports Windows 10 /  Windows 8.1 / Windows 8 / Windows 7 / Windows Vista / Windows XP. 



 

 

Installation Procedure 

Before installing the software, check that your system meets the minimum system requirements: 

Minimum System Requirements: 

 Processor: Pentium Class 

 Operating System: Windows 10 / 8.1 / 8 / 7 / Windows Vista / XP. 

 Memory: Minimum 1 GB 

 Hard Disk: 50 MB of Free Space 

 

To install the software, follow these steps: 

 Double-click StellarPhoenixWindowsBackupRecovery.exe executable file to start installation. 

Setup- Stellar Phoenix Windows Backup Recovery dialog box is displayed. 

 Click Next. License Agreement dialog box is displayed. 

 Choose I accept the agreement option. Next button will be enabled. Click Next. Select 

Destination Location dialog box is displayed. 

 Click Browse to select the destination path where the setup files will be stored. Click Next. Select 

Start Menu Folder dialog box is displayed. 

 Click Browse to provide path for program's shortcuts. Click Next. Select Additional Tasks dialog 

box is displayed. 

 Choose the check boxes as per your choice. Click Next. Ready to Install dialog box is displayed.  

 Review the entries. Click Back if you want to change them. Click Install to start installation. The 

Installing window shows the installation process. 

 After completing the process, Completing the Stellar Phoenix Windows Backup Recovery 

Setup Wizard window is displayed. Click Finish. 

Note: Clear Launch Stellar Phoenix Windows Backup Recovery check box before clicking Finish to 

prevent the software from launching.  

  



Launching the Software 

To launch Stellar Phoenix Windows Backup Recovery in Windows 10 / Windows 8: 

 Click Stellar Phoenix Windows Backup Recovery tile on the home screen. Or, 

 Double click Stellar Phoenix Windows Backup Recovery icon on the desktop. 

 

To start the application, do one of the following in Windows 7 / Vista / XP: 

 Click Start -> All Programs -> Stellar Phoenix Windows Backup Recovery -> Stellar Phoenix 

Windows Backup Recovery. Or, 

 Double click the Stellar Phoenix Windows Backup Recovery icon on the desktop. Or, 

 Click Stellar Phoenix Windows Backup Recovery icon in Quick launch. 



 

 

User Interface 

 

The main user interface of Stellar Phoenix Windows Backup Recovery is as shown below: 

 

 

 

The user interface contains menus and buttons which allows you to access various features of the 

software. 

  



Menus 

File Menu 

 

Select File 

Use this option to select the backup file. 

Save 

Use this option to save recovered content of the 

backup  file. 

Stop 

Use this option to stop the currently running 

process. 

Exit 

Use this option to exit the application. 

Save Scan Info 

Use this option to save the scan information. 

Load Scan Info 

Use this option to load the saved scan 

information. 

Tools Menu 

 

Save Log 

Use this option to save the log report. 

Clear Log 

Use this option to clear the log report. 

Updates 

Use this option to check for both, latest 

minor and latest major versions available 

online. 



 

 

Activation 

Use this option to activate the software. 

Status Bar and Message Log 

Check/Uncheck these boxes to view or hide 

the Status Bar and Message Log. 

Help Menu 

 

Help 

Use this option to view the help manual for 

the software. 

Purchase 

Use this option to Buy Stellar Phoenix 

Windows Backup Recovery software. 

Support 

Use this option to view the Support page of 

stellarinfo.com 

Knowledgebase 

Use this option to visit Knowledgebase 

articles of stellarinfo.com 

Enquiry 

Use this option to Submit enquiry to 

stellarinfo.com 

About 

Use this option to read information about 

the software. 

  

http://www.stellarinfo.com/
http://www.stellarinfo.com/
http://www.stellarinfo.com/


Buttons 

 

 

Click this button to select the Backup file which you want to recover. 

 

Click this button to search for BKF / ZIP / VHDX files. 

 

Click this button to clear the list of files found in the system. 

 

Click this button to start the recovery process. 

  



 

 

Ordering the Software 

Click http://www.stellarinfo.com/windows-backup-recovery.php to know more about Stellar Phoenix 

Windows Backup Recovery. 

To purchase the software online, please visit http://www.stellarinfo.com/windows-backup-recovery/buy-

now.php. 

Alternatively, click Purchase icon in Help Menu on Menu Bar to purchase the software online.  

Select either of the methods given above to purchase the software. 

Once the order is confirmed, a serial number will be sent to you through e-mail, which would be required 

to activate the software. 

  



Registering the Software 

 

You can visit http://www.stellarinfo.com/windows-backup-recovery.php to download demo version of 

Stellar Phoenix Windows Backup Recovery software. The demo version is just for evaluation purposes 

and you must eventually register the software to use its full functionality. Once you purchase the software, 

you will receive a key using which you can register the software. 

You can register the software using any of the following methods: 

 Online Registration 

After purchasing the software, a serial number will be sent via email, which is required to register 

the software. You need to enter the serial number, which is then verified by a license server and on 

verification, the software is registered. 

 Manual Registration 

To register the software manually, you will need to generate a PHX_REG.txt file and mail it to 

support@stellarinfo.com. After verification of the serial number and purchase details, the site key, 

which is required to register the software manually, will be sent to your email address. 

Note: If the software is downloaded from http://www.stellarinfo.com/windows-backup-recovery.php (i.e., 

ESD version), it must be registered using Serial Number (received through email after purchasing the 

product) to use all the features of the software. 

If the software is installed using the product installation CD (i.e., BOX version), hardware lock, that is 

available with the software kit, is mandatory for the functioning of the software. 

  



 

 

Online Registration 

To register the software online: 

 

 

1. Launch demo version 

of Stellar Phoenix 

Windows Backup 

Recovery software. 

2. In Tools Menu on 

Menu Bar, Click 

Activation. 

3. In Registration 

Option dialog box, 

select I have the 

registration key. 

4. Select Online 

Registration. Click 

OK. A warning will 

appear, click Yes to 

continue.  

5. In Stellar Phoenix - 

Electronic 

Registration Wizard, 

click Next. 

6. Type the serial 

number (received 

through email after 

purchasing the 

product) in serial 

number field. Click 

Next. 

 



 

7. The software would 

automatically 

communicate with the 

license server. After 

the registration is 

done, click Finish to 

complete the 

registration process. 

 

Note: You can generate PHX_REG.txt file manually via online activation. View Manual Registration to 

perform the process of generating PHX_REG.txt file. 

  



 

 

Manual Registration 

To register the software manually: 

1. Launch demo version of Stellar Phoenix Windows Backup Recovery. 

2. In Tools Menu on Menu Bar, click Activation. 

3. In Registration Option dialog box, select I have the registration key. 

4. Select Online Registration. Click OK. A warning will appear, click Yes to continue. 

5. In Welcome to Stellar Phoenix - Electronic Software Registration wizard, click Cancel. 

6. Stellar Phoenix Windows Backup Recovery dialog box will open, click Yes. 

 

7. In Manual Registration dialog box, enter the serial number that you receive once you purchase 

the software. Click Next. 

 

8. A file named PHX_REG.txt is created on your desktop. Email it to support@stellarinfo.com. Click 

Finished. 



 

9. After verifying the purchase details, you will receive the site key, which is required to register the 

software manually. 

10. After receiving the Site Key, open Stellar Phoenix Windows Backup Recovery. In Registration 

Option dialog box, select I have the registration key. 

11. Select Manual Registration and Click OK. 

12. Enter the Site Key in Enter Site Key dialog box. Click Validate. 

    

Note: The site key is delivered to the email address through which the serial number is sent. 

  



 

 

Updating the Software 

Stellar releases periodical software updates for Stellar Phoenix Windows Backup Recovery software. 

You can update the software to keep it up-to-date. These updates can add a new functionality, feature, 

service, or any other information that can improve the software. Updates option of the application is 

capable of checking for latest updates. This will check for both latest minor and major versions available 

online. You can easily download minor version through the update wizard. However, the major version, if 

available, has to be purchased. While updating the software, it’s recommended to close all the running 

programs. Note that demo version of the software cannot be updated. 

To update Stellar Phoenix Windows Backup Recovery: 

 Click Updates icon from Tools Menu. 

 Stellar Phoenix Windows Backup Recovery wizard opens. Click Next. The wizard will search for 

latest updates, and if it finds any new updates, a window will pop up indicating its availability. 

 Click Next and the software will download the files from the update server. When the process is 

complete, the software will upgrade to the latest version. 

Live Update may not happen due to following reasons: 

 Internet connection failure 

 Updates are not available 

 Unable to download configuration files 

 Unable to locate updated files or version 

 Unable to locate executable file 

Note: If a major version is available, you need to purchase the software in order to upgrade it. 

  



Stellar Support 

Our Technical Support professionals will give solutions for all your queries related to Stellar products. 

You can either call us or go online to our support section at http://stellarinfo.com/support/ 

For price details and to place the order, click http://www.stellarinfo.com/windows-backup-recovery/buy-

now.php 

Chat Live with an Online technician at http://stellarinfo.com/support/ 

Search in our extensive Knowledgebase at http://www.stellarinfo.com/support/kb/ 

Submit enquiry at http://www.stellarinfo.com/support/enquiry.php 

E-mail to Stellar Support at support@stellarinfo.com 

Support Helpline 

Monday to Friday [ 24 Hrs. a day ] 

USA (Tollfree- Pre Sales Queries) +1-877-778-6087 

USA (Post Sales Queries) +1-732-584-2700 

UK (Europe) +44-203-026-5337 

Australia & Asia Pacific +61-280-149-899 

Netherlands Pre & Post Sales Support +31-208-111-188 

Worldwide +91-124-432-6777 

Email Orders   orders@stellarinfo.com 

 

http://www.stellarinfo.com/support/
http://www.stellarinfo.com/windows-backup-recovery/buy-now.php
http://www.stellarinfo.com/windows-backup-recovery/buy-now.php
http://www.stellarinfo.com/support/
http://www.stellarinfo.com/support/kb/
http://www.stellarinfo.com/support/enquiry.php
mailto:support@stellarinfo.com

