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Overview 

What is Active Directory? 

Active Directory (AD) is a directory service for Windows domain networks. Its a part of most Windows 

Server operating systems. 

 

Every Active Directory has a domain controller. An AD domain controller authenticates and authorizes all 

users and computers in a Windows domain network. It assigns and enforces security policies for all 

computers and installs or updates software. For example, when a user logs into a computer that is part of 

a Windows domain, Active Directory checks the submitted password and determines whether the user is 

a system administrator or normal user. 

 

Active Directory is a special-purpose database - it is not a registry replacement. Active Directory data is 

hierarchical, replicable, and extensible. Typical examples of data stored in directory include printer queue 

data, user contact data, and network/computer configuration data. Active Directory database consists of 

objects and attributes. Objects and attribute definitions are stored in the Active Directory schema. 

Why do you need Stellar Phoenix Active Directory Repair? 

Now, in case you have a corrupt or damaged active directory database file, Active directory will not work 

properly. You will lose all the configuration data as well as user rights and attribute definition data. In such 

scenario, you can use Stellar Phoenix Active Directory Repair software to repair the damaged active 

directory database file. After repairing, you will get the same rights and properties as they were before. 

You will be able to recover users, groups, computers and their properties. You will also be able to recover 

other objects such as InetOrgPerson, MsMq, Printer, Contact and so on. 

Key Features of Stellar Phoenix Active Directory Repair software 

• Support added for Windows Server 2012. New 

• Repairs Security features and Permissions. New 

• Repairs Security features and Permissions. New 

• Added a Joined Computer feature to manually add a computer to the Active Directory. New 

• Recovers Users and their property. 

• Recovers Groups and their property. 

• Recovers Computers their property. 

• Recovers other objects of Active Directory like InetOrgPerson, MsMq, Printer, Contact and so on. 
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 Order & Register 
How to order Stellar Phoenix Active Directory Repair? 

You can purchase Stellar Phoenix Active Directory Repair software online. For pricing details and to 

place an order, click here. 

 

To know more about the software, click here. 

Alternatively, if you have already downloaded and installed the demo version of the 
software, then you can follow the below mentioned steps: 
 

1. Run Stellar Phoenix Active Directory Repair software. 

2. Click Cancel. 
3. From Help menu, click Purchase option. 

You will be directed online from where you can purchase Stellar Phoenix Active Directory Repair 

software. 

How to register your copy of Stellar Phoenix Active Directory Repair software? 

You can register Stellar Phoenix Active Directory Repair software in the following two 
ways: 

1. When you have an activation key  

2. When you do not have an activation key.  

To register Stellar Phoenix Active Directory Repair software when you have an 
activation code: 
 

1. Run Stellar Phoenix Active Directory Repair software. 

2. Click Cancel. 
3. In Tools menu, click Register option. 

4. In Stellar Phoenix Active Directory Repair Registration Option dialog box, select 'I have the 
registration key' radio option. 

5. In next dialog box, enter User Name and Activation code. 

6. Click OK. 

 

 
Tip: You will receive your activation code for registering the software through email once your 

order is confirmed. 

To register Stellar Phoenix Active Directory Repair software when you do not have an 
activation code: 
 

http://www.stellarinfo.com/windows-tools/active-directory-repair/buy-now.php
http://www.stellarinfo.com/windows-tools/active-directory-repair.php
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1. Run Stellar Phoenix Active Directory Repair software. 

2. Click Cancel. 
3. In Tools menu, click Register option. 

4. In Stellar Phoenix Active Directory Repair Registration Option dialog box, select 'I do not 
have the registration key' radio option. 

5. Click OK and you will be directed online from where you can purchase Stellar Phoenix Active 
Directory Repair software.  

6. Once you buy the software, follow the steps from the above section to register the software. 

 

 
Tip: All manual registration requests take maximum of one business day for completion. 
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Installation Procedure 
 
Before installing the software, please ensure that your system meets the minimum system requirements. 

Minimum System Requirements: 

• Processor : Pentium Processors 

• RAM : 512 MB minimum 

• Hard Disk : 50 MB 

• Operating Systems : Windows Server 2012 / 2008 / 2003 

To install Stellar Phoenix Active Directory Repair software, follow the steps given below: 
 

1. Double-click StellarPhoenixActiveDirectoryRepair.exe setup file to run the setup wizard. Setup 
- Stellar Phoenix Active Directory Repair dialog box is displayed. 

2. Click Next to proceed. License Agreement dialog box is displayed. 

3. Select I accept the agreement option from the License Agreement dialog box. Click Next. 
Select Destination Location dialog box is displayed. 

4. Specify a destination in the text box or click Browse to select a destination. Click Next. Select 
Start Menu folder dialog box is displayed. 

5. Specify a destination in the text box or click Browse to select a destination. Click Next. Select 
Additional Tasks dialog box is displayed. 

6. Select the required check boxes for creating desktop icon and quick launch icon of the software. 

Click Next. 
7. In the Ready to Install dialog box, verify the settings. Click Back to make any changes, or click 

Install to install the software. 

8. After successful installation of the software, the "Completing the Stellar Phoenix Active 
Directory Repair Setup Wizard" screen opens. Click Finish. 
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Launching the Software 
 
To launch Stellar Phoenix Active Directory Repair, use any one of the following 
methods: 
 
Click Start -> Programs -> Stellar Phoenix Active Directory Repair -> Stellar Phoenix Active 
Directory Repair. 

 

Or, 
 

Click Stellar Phoenix Active Directory Repair desktop icon. 

 

Or, 
 

Click Stellar Phoenix Active Directory Repair in Quick Launch tool bar. 
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Updating the Software 
Stellar Phoenix Update Wizard keeps your copy up-to-date. The wizard runs the update process and 

automatically checks for updates. You need an active internet connection to check for updates using 

Update option of the application. Using Update option, you can check for both, latest minor and major 

versions available online. You can easily download minor versions using the update wizard. However, 

you need to purchase any major version updates whenever they are available. 

To start Stellar Phoenix Update Wizard: 
 

1. Run Stellar Phoenix Active Directory Repair software. 

2. Click Cancel. 
3. In next screen, from Tools menu, click on Update option. 

4. 'Stellar Phoenix Update Wizard' window pops up. Click Next to proceed. 

5. The wizard will start searching for the latest updates and if it finds any new version, a window will 

pop up indicating the availability an update. 

6. Click Next and the software will start downloading update files from the server. When the process 

is complete, the software will updated to the latest version. 

Live Update may not happen due to following reasons: 
 

• Internet connection failure 

• Unable to download configuration files 

• Unable to locate updated files or version 

• Unable to locate executable file 

 

 
Tip: You need to purchase the major version updates of the software, whenever they are 

available. 
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Stellar Support 
 
Our Technical Support professionals will provide solutions for all your queries related to Stellar Products. 

 

To know more about the product, visit http://www.stellarinfo.com/windows-tools/active-directory-repair.php  

You can either Call Us or Go Online to our support section at http://stellarinfo.com/support/ 

For price details and to place an order, click http://www.stellarinfo.com/windows-tools/active-directory-

repair/buy-now.php 

Chat Live with an Online technician at http://stellarinfo.com/support/ 

Search in our extensive Knowledge Base at http://www.stellarinfo.com/support/kb/ 

Submit enquiry at http://www.stellarinfo.com/support/enquiry.php 

E-mail to Stellar Support at support@stellarinfo.com 
 

Stellar Support Helpline 

Monday to Friday [ 24 Hrs. a day ] 

USA (Toll free- Pre Sales Queries) +1-877-778-6087 

USA (Post Sales Queries) +1-732-584-2700 

UK (Europe) +44-203-026-5337 

Australia & Asia Pacific +61-280-149-899 

Netherlands Pre & Post Sales Support +31-208-111-188 

Worldwide +91-124-432-6777 

Skype Id stellarsupport 

Email Orders   orders@stellarinfo.com 

http://www.stellarinfo.com/windows-tools/active-directory-repair.php
http://stellarinfo.com/support/
http://www.stellarinfo.com/windows-tools/active-directory-repair/buy-now.php
http://www.stellarinfo.com/windows-tools/active-directory-repair/buy-now.php
http://stellarinfo.com/support/
http://www.stellarinfo.com/support/kb/
http://www.stellarinfo.com/support/enquiry.php
mailto:support@stellarinfo.com?
mailto:orders@stellarinfo.com?subject=Purchase%20Order
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Menus & Buttons 
 
Stellar Phoenix Active Directory Repair software has three menus using through which you can 

perform the required operations on the damaged Active Directory database file (ntds.dit file).  

The menus & buttons Stellar Phoenix Active Directory Repair software are as follows: 

File Menu 

Select - Use this option to browse to and select / 

open a damaged ntds.dit file. 

 
 

File Menu 

Repair - Use this option to repair the selected / 

opened damaged ntds.dit file. 

Stop - Use this option to stop / abort the repairing 

process of the damaged ntds.dit file. 

Join Computer - Use this option to manually join 

computers to Active Directory. 

Exit - Use this option to quit the application. 

Log Window - Select this check box to view the log 

window. 

Tools Menu 

Save Log - Use this option to save a log of the 

present repair process. 

 
 

Tools Menu 

Clear Log - Use this option to clear the existing log 

of a repair process. 

Register - Use this option to register your copy of 

Stellar Phoenix Active Directory Repair software 

electronically. 

Update - Use this option to update your copy of 

Stellar Phoenix Active Directory Repair software. 

Help Menu 

Purchase - Use this option to purchase Stellar 
Phoenix Active Directory Repair online. 
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Submit Enquiry - Use this option to submit a query 

regarding the software to Stellar support. 

 

Help Menu 

KnowledgeBase - Use this option to view Stellar's 

vast online KnowledgeBase database for 

information regarding Stellar Phoenix Active 
Directory Repair software. 

Help - Use this option to view / access Stellar 
Phoenix Active Directory Repair software's help. 

About - Use this option to view information 

regarding the software. 
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Select, Scan & Preview AD Database File 
 
Before you begin repairing an active directory database file you first need to re-install Active Directory 

with the same domain name. 

Before selecting and repairing an AD database file, follow the below-mentioned steps: 
 
1. Follow the steps given below to copy 

active directory database file ntds.dit: 

i.Attach the HDD of the corrupt server as a 

slave to a working computer. 

ii.Locate database 'ntds.dit' and copy it to 

another location. This database contains all 

data related to corrupt Active directory. 

iii. Re-install active directory with 

same domain name. 

iv. Install Stellar Phoenix Active 
Directory Repair software to this new 

server with active directory. 

v. Copy AD database file ntds.dit to 

the new server. 
 

 

Steps To Follow screen 

 
Once you have performed the steps given above, do the following. 

To select, scan & preview the content of an AD database file: 
1. Run Stellar Phoenix Active 

Directory Repair software. 

2. Select 'I have read all the above 
given instruction carefully.' Click 

Proceed. 

3. In Select Database File dialog 

box, click Select File button to 

browse to the corrupt / damaged 

ntds.dit file. 

4. Select the corrupt / damaged 

ntds.dit file and click Open. 

5. Click Scan button to start scanning 

 
 

Scan & Preview screen 
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the ntds.dit file. 

6. Once the scanning is complete, on 

the left pane of the software will 

display all the Active Directory 

contents in a hierarchal tree 

structure. 

7. You can expand the tree structure 

and click on the nodes (such as 

Organizational Unit, Contacts, 

Computer, MSMQs, MSimaging, 

Groups, InetOrgPersons, and 

Users) and preview them in the 

right pane of the application. 
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Repair AD Database File 
To repair a corrupt / damaged AD database file, follow the steps given below: 

1. Run Stellar Phoenix Active 
Directory Repair software. 

2. Select 'I have read all the above 
given instruction carefully.' Click 

Proceed. 

3. In Select Database File dialog box, 

click Select File button to browse to 

the corrupt / damaged ntds.dit file. 

4. Select the corrupt / damaged ntds.dit 

file and click Open. 

5. Click Scan button to start scanning 

the ntds.dit file. 

6. Once the scanning is complete, on 

the left pane of the software will 

display all the Active directory 

contents in a hierarchal tree 

structure. 

7. Now, from File menu, click on 

Repair option. 

 
 

Repair screen 

8. The next screen has a number of options, they are as follows: 

i. Password Mode - In this section you can either set the same default password for all the 

users (the Default Password option) or set a distinct / unique password for each of the 

users (Random Password option). 

ii. Browse - Use this button to browse to a location of your choice and save a copy of the 

User Name and Password list. 

iii. User must change password at Next Logon - Select this checkbox to force the user to 

change his / her password when they login the second time. 

9. Make the appropriate changes and then click OK. 

A 'File Repaired Successfully' message is displayed once the repair process is over. 
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Manually Join Computers to Active Directory 
You, now, have the option of manually joining computers to the Active Directory. You can do so by using 

the Join Computer option from File menu. 

To manually join computers to Active Directory using Join Computer feature follow the 
steps given below: 

 
 

Join Computers screen 

1. Run Stellar Phoenix Active 
Directory Repair software. 

2. Select 'I have read all the 
above given instruction 
carefully.' Click Proceed. 

3. In Select Database File 

dialog box, click Select File 

button to browse to the 

corrupt / damaged ntds.dit 

file. 

4. Select the corrupt / damaged 

ntds.dit file and click Open. 

5. Click Scan button to start 

scanning the ntds.dit file. 

6. Once the scanning is 

complete, on the left pane of 

the software will display all 

the Active Directory contents 

in a hierarchal tree structure. 

7. Now, from File menu, click 

on Repair option. Make the 

appropriate changes and 

then click OK. 

8. From File menu, click Join Computer icon. Join Computer dialog box will open. 

9. From the list of computers from the Join Computer dialog box, select the computers which you 

want to add to Active Directory. 

10. Click Join. 

All the selected computers will be added to Active Directory. 
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Tip: Incase, you want to add all the computers, you can select the Select All checkbox and then click on 

Join button to add them to Active Directory. 
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Save & Clear Logs 
 
To save log of Stellar Phoenix Active Directory Repair software, follow the steps given 
below: 

1. Run Stellar Phoenix Active Directory Repair software. 

2. Select 'I have read all the above given instruction carefully.' Click Proceed. 

3. In Select Database File dialog box, click Select File button to browse to the corrupt / damaged 

ntds.dit file. 

4. Preview and repair a file, then from Tools Menu, click Save Log option. 

5. In Save As dialog box, browse to a location of your choice, type a File Name for the log file and 

click Save. 

The log file is saved at the desired location. 

To clear the log of Stellar Phoenix Active Directory Repair software, follow the steps 
mentioned below: 
 

1. Run Stellar Phoenix Active Directory Repair software. 

2. Select 'I have read all the above given instruction carefully.' Click Proceed. 

3. In Select Database File dialog box, click Select File button to browse to the corrupt / damaged 

ntds.dit file. 

4. Preview and repair a file, then from Tools Menu, click Clear Log option. 

Stellar Phoenix Active Directory Repair software's log will be deleted. 
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FAQs 
What all can I do using the demo version of Stellar Phoenix Active Directory Repair software? 

You can scan and preview the contents of an active directory file (ntds.dit file) but cannot repair and save 

it. 

 

Is it necessary to rename Active Directory in the new server with the same domain name? 

Yes, its absolutely necessary to re-install Active Directory with the same domain name. 

 

Can I attach the corrupt Active Directory server hard drive as a master in a working computer? 

No, you cannot. You need to attach the corrupt Active Directory server hard drive as a slave only to a 

working computer. 
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Legal Notice 

Copyright 

Stellar Phoenix Active Directory Repair software, accompanied user manual and documentation are 

copyright of Stellar Information Technology Private Limited, with all rights reserved. Under the copyright 

laws, this user manual cannot be reproduced in any form without the prior written permission of Stellar 

Information Technology Private Limited. No Patent Liability is assumed, however, with respect to the use 

of the information contained herein. 

Copyright © Stellar Information Technology Private Limited. All rights reserved. 

Disclaimer 

The Information contained in this manual, including but not limited to any product specifications, is subject 

to change without notice. 

 

STELLAR INFORMATION TECHNOLOGY PRIVATE LIMITED PROVIDES NO WARRANTY WITH 
REGARD TO THIS MANUAL OR ANY OTHER INFORMATION CONTAINED HEREIN AND HEREBY 
EXPRESSLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR 
ANY PARTICULAR PURPOSE WITH REGARD TO ANY OF THE FOREGOING STELLAR 
INFORMATION TECHNOLOGY PRIVATE LIMITED ASSUMES NO LIABILITY FOR ANY DAMAGES 
INCURRED DIRECTLY OR INDIRECTLY FROM ANY TECHNICAL OR TYPOGRAPHICAL ERRORS 
OR OMISSIONS CONTAINED HEREIN OR FOR DISCREPANCIES BETWEEN THE PRODUCT AND 
THE MANUAL. IN NO EVENT SHALL STELLAR INFORMATION TECHNOLOGY PRIVATE LIMITED, 
BE LIABLE FOR ANY INCIDENTAL, CONSEQUENTIAL SPECIAL, OR EXEMPLARY DAMAGES, 
WHETHER BASED ON TORT, CONTRACT OR OTHERWISE, ARISING OUT OF OR IN CONNECTION 
WITH THIS MANUAL OR ANY OTHER INFORMATION CONTAINED HEREIN OR THE USE 
THEREOF. 

Trademarks 

Stellar Phoenix Active Directory Repair® is a registered trademark of Stellar Information Technology 

Private Limited. 

Windows XP®, Windows Vista®, Windows 7®, and Windows 8® are registered trademarks of Microsoft® 

Corporation Inc. 

All Trademarks Acknowledged. 

All other brands and product names are trademarks or registered trademarks of their respective 

companies. 
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License Agreement 

Stellar Phoenix Active Directory Repair 

Copyright © Stellar Information Technology Private Limited. INDIA 

www.stellarinfo.com 

All rights reserved. 

All product names mentioned herein are the trademarks of their respective owners. 

This license applies to the standard-licensed version of Stellar Phoenix Active Directory Repair. 

Your Agreement to this License 

You should carefully read the following terms and conditions before using, installing or distributing this 

software, unless you have a different license agreement signed by Stellar Information Technology Private 

Limited. 

 

If you do not agree to all of the terms and conditions of this License then do not copy, install, distribute or 

use any copy of Stellar Phoenix Active Directory Repair with which this License is included, you may 

return the complete package unused without requesting an activation key within 30 days after purchase 

for a full refund of your payment. 

 

The terms and conditions of this License describe the permitted use and users of each Licensed Copy of 

Stellar Phoenix Active Directory Repair. For purposes of this License, if you have a valid single-user 

license, you have the right to use a single Licensed Copy of Stellar Phoenix Active Directory Repair. If 

you or your organization has a valid multi-user license, then you or your organization has the right to use 

up to a number of Licensed Copies of Stellar Phoenix Active Directory Repair equal to the number of 

copies indicated in the documents issued by Stellar when granting the license. 

Scope of License 

Each Licensed Copy of Stellar Phoenix Active Directory Repair may either be used by a single person or 

used non-simultaneously by multiple people who use the software personally installed on a single 

workstation. This is not a concurrent use license. 

 

All rights of any kind in Stellar Phoenix Active Directory Repair, which are not expressly granted in this 

license, are entirely and exclusively reserved to and by Stellar Information Technology Private Limited. 

You may not rent, lease, modify, translate, reverse engineer, decompile, disassemble or create derivative 

works based on Stellar Phoenix Active Directory Repair nor permit anyone else to do so. You may not 

make access to Stellar Phoenix Active Directory Repair available to others in connection with a service 

bureau, application service provider or similar business nor permit anyone else to do so. 

http://www.stellarinfo.com/
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Warranty Disclaimers and Liability Limitations 

Stellar Phoenix Active Directory Repair and all accompanying software, files, data and materials are 

distributed and provided AS IS and with no warranties of any kind, whether expressed or implied. You 

acknowledge that good data processing procedure dictates that any program including Stellar Phoenix 

Active Directory Repair must be thoroughly tested with non-critical data before there is any reliance on it 

and you hereby assume the entire risk of all use of the copies of Stellar Phoenix Active Directory Repair 

covered by this License. This disclaimer of warranty constitutes an essential part of this License. In 

addition, in no event does Stellar authorize you or anyone else to use Stellar Phoenix Active Directory 

Repair in applications or systems where its failure to perform can reasonably be expected to result in a 

significant physical injury or in loss of life. Any such use is entirely at your own risk and you agree to hold 

Stellar harmless from any and all claims or losses relating to such unauthorized use. 

 

In no event shall Stellar Information Technology Private Limited or its suppliers be liable for any special, 

incidental, indirect, or consequential damages whatsoever (including, without limitation, damages for loss 

of business profits, business interruption, loss of business information, or any other pecuniary loss) 

arising out of the use of or inability to use the software product or the provision of or failure to provide 

support services, even if Stellar Information Technology Private Limited has been advised of the 

possibility of such damages. In any case, Stellar Information Technology Private Limited’s entire liability 

under any provision shall be limited to the amount actually paid by you for the software product. 

General 

This License is the complete statement of the agreement between the parties on the subject matter and 

merges and supersedes all other or prior understandings, purchase orders, agreements and 

arrangements. This License shall be governed by the laws of the State of Delhi, India. Exclusive 

jurisdiction and venue for all matters relating to this License shall be in courts and fora located in the 

State of Delhi, India and you consent to such jurisdiction and venue. There are no third party beneficiaries 

of any promises, obligations or representations made by Stellar herein. Any waiver by Stellar of any 

violation of this License by you shall not constitute nor contribute to a waiver by Stellar of any other or 

future violation of the same provision or any other provision of this License. 

 

Copyright © Stellar Information Technology Private Limited. All rights reserved. 
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About Stellar 
Stellar Information Technology Private Limited is a trusted name in the field of Data Recovery and Data 

Protection Software for more than a decade. 

 

We provide the widest range of Data Recovery Products. Our range includes Data Recovery Software for 

almost all Operating Systems and File Systems. 

Product Line: 

Data Recovery 

A widest range of data recovery software that helps you recover your valued data lost after accidental 

format, virus problems, software malfunction, file/directory deletion, or even sabotage!. More Info >> 

File Recovery 

The most comprehensive range of file undelete and unerase software for Windows and MS office repair 

tools. More Info >> 

Email Recovery 

A wide range of mail recovery, mail repair and mail conversion applications for Outlook, Outlook Express 

and Exchange useful in instances of data loss due to damages and corruption of Email. More Info >> 

Data Protection 

A wide range of Prevent Data Loss, Data backup and Hard Drive Monitoring Applications to ensure 

complete data protection against hard drive crash. More Info >> 

 

For more information about us, please visit www.stellarinfo.com 

 
 

http://www.stellarinfo.com/disk-recovery.htm
http://www.stellarinfo.com/undelete.htm
http://www.stellarinfo.com/mail-recovery.htm
http://www.stellarinfo.com/prevent-dataloss.htm
http://www.stellarinfo.com/
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