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Introduction 
This is the first release of Stellar Active Directory Manager tool documentation. The contents will be 

updated periodically to incorporate new information, updates, customer feedback, and corrections. 

 

Stellar Active Directory Manager, from Stellar Information Technology Private Limited, is a tool that 

meets all your requirements related to Windows Active Directory Management. It is a simple, easy-to-

use Management tool that helps Active Directory Administrators with their day-to-day activities across 

the domains from a central platform. The tool also offers a simple and robust mechanism to generate 

reports on various Active Directory objects and query Active Directory. An intuitive and easy-to-use 

interface, helps handle a variety of complex tasks like Bulk Management of User accounts, and other 

Active Directory objects in an efficient manner. The tool also lets you manage Domains, Services, 

Event Logs, Registry, Printers and more. 

 

Key Features 

 Eliminates repetitive logon, everyday and complex tasks associated with AD Management.  

 Hierarchical representation of various network resources of domain and support for various 

operations. 

 Facilitates creation, deletion and management of AD objects in Bulk.  

 OU-based administration. 

 Manages Account Policy and Audit Policy on the server and target computers. 

 Manages Printers and other devices remotely and locally. 

 Manages Shares available over the network. 

 Enables creation of network drive from Shares. 

 Enables viewing of sessions, files and disk space of target computers. 

 Manages Services, Objects, Events and Job scheduling. 

 Query Active Directory for multiple users and computers. 
 Generates AD Reports. 
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In this documentation set, Stellar Active Directory Manager will be sometimes 
referred to as Active Directory Manager or ADM and Active Directory will be 
referred to as AD. 
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Installation 

This documentation assumes you have installed Windows Server and AD (Active Directory) on the 
servers that you want to use as Domain Controllers. It also assumes: 
 

 A basic understanding of what AD is, how it works, and why your organization uses it to 
access, manage, and secure shared resources across your network.  

 A thorough understanding of how AD is deployed and managed in your organization.  
 An understanding of the mechanism your organization uses to configure and manage Active 

Directory settings.  
 You have installed Windows Server and AD on the servers that you want to use as Domain 

Controllers.  
 
This section will describe in detail the following topics:   
 

 System Requirements 
 Installing Active Directory Manager 
 Uninstalling  Active Directory Manager 
 Registering Active Directory Manager 
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System Requirements 

Before you start installing the Stellar Active Directory Manager, ensure that your computer meets the 
following requirements.  
 
Operating Systems 
 

 Windows Server 2003 
 Windows Server 2008 
 Windows 7 
 Windows 8 
 Windows XP 
 Windows Vista 

 
 
Hardware Requirements 
 

 x86 or x64 Processor 
 RAM: Minimum 1 GB, Recommended 2GB 
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Installing Active Directory Manager 

You need to follow few simple and intuitive steps to install Stellar Active Directory Manager. This 
section includes the sequential steps to install  the tool. 
 
Before you start installation, ensure that you have the tool setup file - 
StellarActiveDirectoryManager.exe on your machine. You can either download the executable file 
or buy it online. 
 
After downloading the file, double click on it to invoke the installer and follow the instructions to install 
the tool. 
 

1. Stellar Active Directory Manager Setup Wizard is displayed. 
2. Click Next to continue with the installation process. 
3. Select I accept the agreement and click Next to continue. 
4. Specify the destination location to install the tool. You can either install it in the default 

location that is displayed or you can Browse to select a different install location. 
5. Select the default Start Menu Folder or Browse to select another folder to create the Program 

shortcuts in the selected folder, and continue with the install process. 
6. Select the required Additional Tasks option to create tool shortcuts like Create a desktop icon 

and Create a Quick Launch icon. 
7. The setup is ready to start the installation process. Check the details. If you need to edit the 

details, click Back to return to previous screens, edit the details as required, and proceed with 
the installation. 

8. Click Install to start the installation process. 
9. By default the Launch Stellar Active Directory Manager check box option is selected. If you 

decide to invoke the tool at a later stage, you may clear the selection. Click Finish to 
complete the install process. 

10. After the successful installation, Stellar Active Directory Manager is launched. Before you 
proceed to use the tool, you will be prompted to register the tool. 

11. Alternatively you can launch the tool later through Windows Start Menu. To launch the tool 
from the Start Menu: 

12. Click Start > All Programs > Stellar Active Directory Manager. 
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Uninstalling Active Directory Manager 

If you need to uninstall the tool, follow the steps mentioned below:  
 

1. Click Start > All Programs > Stellar Active Directory Manager > Uninstall Stellar 
Active Directory Manager to Uninstall the tool. 

     OR 
Go to Windows > Control Panel> Add Remove Programs > Stellar Active Directory 
Manager > Uninstall. A corresponding alert is displayed.   

 

 
 

2. Click Yes to continue uninstalling the Active Directory Manager. After the successful 
uninstallation, the following alert is displayed. Click OK to complete the uninstallation process. 

 
 

 
 
 
 

 

Sometimes the uninstall process fails to remove all the files from the 
install folder. In such cases, it is recommended that you remove the 
files manually, before re-installing the tool. 
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Registering Active Directory Manager 

When you launch the tool for the first time, you will be prompted to enter a security key (which you 
will receive from Stellar in your email). Click on OK to enter the key to register the software.  
 
After registering Stellar Active Directory Manager, you can use the software for a period of one year. 
 
In case you want to use the tool for more than a year, you will have to renew your subscription. To 
renew your subscription, select Help > Purchase. Clicking on Purchase will take you to the buy page 
of the software. Once you renew it, you will receive a User Name and Registration Key in your mail. 
Go to Tools > Register to renew your copy of Active Directory Manager. 
 
You will be able to use the software till your subscription expires. 
 
 
  

 

You need an active internet connection to purchase the product online. In case 
of any issues, please contact support@stellarinfo.com for assistance. 

 
 

mailto:support@stellarinfo.com
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User Guide Introduction 

The User Guide contains sequential steps to guide and assist you through the various Active Directory 
Manager functions. Each function is explained in detail in the corresponding sections. The guide covers 
the following major topics: 
 
 

 User Management 
 Group Management 
 Computer Management 
 Group Policy Management 
 Query Management 
 Container Management  
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Getting Started 

When you launch the tool after registration, you will be prompted to enter and verify the password 
to lock the application. This is a safety option and can be skipped. However, it is recommended 
to lock the application when not in use.  
 

 
 

Active Directory Manager User Interface 

On launching the tool, the  Stellar Active Directory Manager node appears in the left panel. On 
expanding the node, you will see the sub-nodes that help you manage the AD objects on local as well 
as Domain Computers. The Computers node represents the computers which are added to this 
domain. On expanding this node, various sub-nodes are displayed and helps you manage the objects 
on the computer.  
 
The SADM User Interface is intuitive and easy to use. This section will explore the interface as follows: 
 

 Left Panel - displays the SADM node and sub-nodes - Users, Groups, Computers, 
Containers/OUs. 

 Middle Panel - displays the tree of the selected sub-node. For example if you select Users in 
the left panel the middle panel will display the complete list of users. 

 Right Panel - displays the details of each object selected in the middle panel. 
 Menu Bar - displays the available menus. 
 Tool Bar - displays the toolbar options associated with each menu. 

 
Refer the illustration below to identify the above sections in the interface. 
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You can manage single or multiple domains. You can also add domains manually as required. The 
illustration below displays the Stellar Active Directory Manager GUI and the available functions.  
 
The table below shows the available menu options and the description of each. 
 
 

Name  Description 
File Menu 
Options 

 

Add Domain Click to add a new domain manually. The 
new domain will be listed in the left panel 
under the Stellar Active Directory 
Manager node. 

Lock application Use this option to lock your application 
when unattended for a long duration. 

Reports Use this option to generate the various 
AD Reports. 

Query Manager Use this option to query Active Directory 
for multiple Users and Computers. 

Group Policy 
Management  

Use this option to manage user settings 
on multiple computers at once,  specify 
options for groups of computers and 
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users, link group policies, and manage 
and enforce group policies.  

Tools Menu 
Options 

 

Online Activation Use this option to activate the tool online. 
Manual 
Activation 

Use this option to activate the tool 
manually. 

Update Use this option to check for and download 
online tool updates. 

Apply Filter Use this option to apply filters to your 
selection. 

Help Menu 
Options 

 

Purchase This option is available only with demo 
copies of the tool. Use this option to 
place online order for the tool. 

Submit Enquiry Use this option to submit your enquiry. 
Clicking the option leads to Stellar's 
support page. 

Knowledgebase Jumps to Stellar's Online Support page. 
Help Displays the tool documentation. 
About Displays the company details  
Quick Access 
Toolbar 

Use this option to customize the toolbar 
and keyboard shortcuts. For details refer 
to Customize Quick Access Toolbar. 
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Customize Quick Access Toolbar 

Active Directory Manager includes menus and commands. You can change the way these menus and 
commands appear by using the Customise Quick Access Toolbar option. This option helps customize 
the toolbar and keyboard shortcuts to provide immediate access to the options. You can also choose 
to display the toolbar buttons below or above the ribbon. The Minimize the Ribbon feature can be 
efficiently used when you need to display more number of objects and details in the left and the right 
panel simultaneously. 
 
To customize the toolbar: 
 

1.  Click the drop-down arrow button on the top-left corner of the interface or on the top-right 
corner of the left panel. The options available are: 

 

 
 

2. Select the More Commands.. option to display the Customize dialog. 
 
To customize the toolbar: 
 

3. Select a menu option from Choose Commands from drop-down list. The selected menu 
displays the corresponding commands in the left panel.  

4. Select a command and click Add to append it in the right panel and click OK to save the 
changes.  

5. Reset option allows you to return to the previous selection. 
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6. Click Customize to display the Customize Keyboard dialog as illustrated below.   
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7. In the Customize Keyboard dialog,  select the menu that contains the command you want to 

assign a shortcut to. Enter a new shortcut key in the Press new shortcut key text box. If the 
key combinations entered matches an existing shortcut, it will be displayed against Assigned 
to field. It means you need to define a different set of keys. The non-matching key 
combination will be displayed against [Unassigned] field. Click Assign to save the key 
combination. The Description field displays the command description. The new shortcut 
created will be displayed in the Current Keys list box.  Click Close to save the changes and 
exit the dialog, 

8. The Set Accelerator for option specifies when the keyboard shortcut is available. If Default is 
selected, it indicates that the keyboard shortcut is available in general. 

9. Click Reset All,  to restore all of the keyboard shortcuts available when you first started AD 
Manager.  

   
   
     
 
 



16 

 

 

Stellar  
Active Directory Manager 
 

Adding a Domain Manually 

With Active Directory Manager you can manage a single or multiple domains. After installation, when 
you invoke the tool, by default the existing domains are listed in the left panel. However, if the 
domains are not listed in the left panel, you can add them manually. You can add any number of 
domains. With Active Directory Manager, you can manage local and remote domains from a central 
location. 
 
To add a domain: 
 

1. Click the Add Domain toolbar option. The Add Domain Manually dialog is displayed. 
 

 
 

2. In the dialog, type the Domain Name, User Name and Password. Click Add Domain. The 
domain added, is appended to the list in the left panel.  You can expand the domain node to 
display the child nodes corresponding to Organizational Units, Domain Controllers, and 
Groups- local, global, and universal. 

 
You can right-click the domain name node in the left panel and view its Properties and FSMO Roles.  
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Domain Properties 

You can view the properties of any of the domains listed in the left panel. 
 
To view the domain properties: 
 

 Select the domain in the left panel and right-click, select Properties from the pop-up menu. 
The Domain Properties dialog is displayed. 

 

 
 
The dialog displays the following details: 
 
Domain Name: The selected domain name is automatically populated. 
Description: You can enter a domain description as required. 
Object Information: These are system generated details and cannot be modified. 
 
After viewing the details, click OK to exit the dialog. 
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View FSMO Roles 

The FSMO is responsible for managing and ensuring the smooth running of the AD infrastructure. The 
role includes five level of operations that are automatically installed.  
 
To view the FSMO roles: 
 

 Right-click the domain name in the left panel, select View FSMO Roles. The FSMO Roles screen 
is displayed as illustrated below: 

 

 
 
The screen displays five level of operations as described below: 
 

Operations  Description 
Schema Master  The Schema Master controls all updates and modifications 

to the schema. The schema is shared between every Tree 
and Domain in a forest and must be consistent between 
all objects. 

Domain Naming Master A new Domain added to a forest must have a unique 
name within the forest.  The Domain naming master is 
responsible for identifying the entire forest area, and 
must be available when adding or removing a Domain in 
a forest. 

Infrastructure Master The user-group references are modified or updated by 
the Infrastructure Master.  

RID Master The RID Master's  responsibility is to allocate RIDs to DCs 
within a Domain.  

PDC Emulator The PDC Emulator handles changes to user accounts  
and emulates an NT PDC for backward compatibility. 
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User Management 

Managing Active Directory is challenging to most IT Administrators. In a large and complex windows 
network, manual configuration of user properties is a herculean task and also error-prone.  To perform 
these tasks the administrator needs to be very efficient, as it demands specialization as well as quick 
action. Stellar Active Directory Manager makes it possible to manage single as well as multiple users 
simultaneously and thus saves time and effort. The User Management module helps perform the 
following functions efficiently: 
 

 Creating New User 
 Single User Management 
 Single User Properties 
 Bulk User Management 

 
The above functions are further explained in detail in the subsequent sections. 
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Create New User 

Routine tasks of Administrators include creating multiple users which requires time and effort. With 
Active Directory Manager, you can create users manually or you can create bulk users by importing 
.CSV file that contains the necessary user attributes. Thus, with a single attempt you can create users 
in bulk and save on time. 
 
To create a new user: 
 

1. Select All Users > New User. The Create New User dialog is displayed.  
2. Click Browse to select the container in which you want to create the user. By default the 

Users container of the selected domain is populated. 
3. Type the User Name, Password and Confirm Password.  

 

 
 

3. Select the option Copy Properties of another user,  to create a new user with the properties of 
an existing user.  

4. Click Set Properties to set the new user properties. 
5. You can continue to add more users to the container by selecting the option, Add another 

User. 
6. Click Create, to create the user in the selected container. 
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Single User Management 

The Active Directory Manager helps the administrator to modify user attributes and reset password, 
rename user, move user to another container, etc.  
 
Under the Active Directory node, select the sub-node Users and double-click to expand the list. The 
expanded list is displayed in the middle panel as illustrated below. Select a user and right-click to view 
the available management options. 
 

 
 

Copying a User 
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Use this option to copy a selected user to another container. To copy a user: 
 

1. Select User > Copy. The Copy User dialog is displayed. 
 

 
 

2. In the dialog, type and confirm the password and click on Copy.  The corresponding container 
list is displayed. 

 

 
 

3. Select the container where you want to copy the user and click OK.  

Moving a User 

Use this option to move a user from one container to another.  To move a user: 
 

 Select User > Move.  Select the container to which you want to move the user and click OK to 
complete the action. 
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Disable Account 

Use this option to remotely disable any user account. 
 

 Select User > Disable Account. Click Yes to confirm the action. 
 

Enable Account 

Use this option to remotely enable a user account.  
 

 Select User > Enable Account. Click Yes to confirm the action. 
 

Reset Password 

Use this option to remotely reset the user password in any domain. 
 

1. Select User > Reset Password.  
2. In the Reset Password dialog, enter the new password and for security purpose it is 

recommended to select the option User must change password at next logon.  
3. If the user account is locked, you can unlock it by selecting the corresponding check box 

option. 
 

 

Unlock Account 

Use this option to remotely unlock the locked out user account. 
 

 Select User > Unlock Account. Click Yes to confirm the action. This menu option is enabled 
only if the user account is locked, else the option appears disabled in the right-click menu. 

 

Delete User 

Use this option to remotely delete a user in any domain.  
 

 Select User > Delete. Click Yes to confirm the action. 
 

Rename User 
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Use this option to remotely rename a user in any domain.  
 

 Select User > Rename. In Rename User dialog enter the applicable details and click OK to 
save the changes. 

 

 

View Logon Information 

Use this option to view the total number of successful and failed logon information of any user 
account.  
 

 Select User > View Logon Information. Click OK to exit the dialog. 
 

 

View Details 

Use this option to remotely view the details of any selected user.  
 

 Select User > View Details. The user details like the Attribute Name and Attribute Value is 
displayed in the right panel. 

Permissions 
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Use this option to view the permissions of any user. 
 

 Select User > Permissions.  The permission details like the Object Name, Access Type, 
Trustee, and Permission Type are displayed in the right panel. 

 

Set Group Attributes 

This option helps you set Group attributes of a user. You can add a user to a group, remove user from 
the group or set the user primary group. 
 

 Add to Group 
Select User > Add to Group. When the Add to Group dialog is displayed select the group to which 
you want to add the user and click OK. 

 Remove from Group 
Select User > Remove from Group. In the Remove from Group dialog, select the group, to remove 
the user from the group and click OK. 

 Set Primary Group 
Select User > Set Primary Group. In the Set Primary Group dialog, select the group and click OK. 
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Single User Properties 

The Stellar Active Directory Manager, helps the administrator to set and modify the individual user 
attributes and reset password, rename user, move user to another container and enable or disable a 
user account. The illustration below displays the User Properties' tabbed dialog. Each tab page is 
explained in detail in the subsequent sections 
 

 
 
General 
 
Use this page to modify the user properties like Display Name, define password limitations like User 
Cannot Change the Password, Password Never Expires, Must Change the Password at Next Logon and 
so on. You can also modify the user's other attributes such as Office, Telephone number, E-mail and 
Web Page as well. 
 
Contact 
 
Use this page to modify the user contact details and instructions if any. 
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Account and Member of 
 
Use this page to modify the user account options, Group Name and Container Path details. The 
account options that can be modified are: 
 

Account Options Description 
Store Password using 
reversible encryption 

If the option is enabled, the settings decides if the operating system 
stores the password using reversible encryption. By default the option 
is disabled. 

Smart Card is required 
for interactive logon 

If the option is selected, the user can only log on to the computer 
interactively using a smart card. If the option is cleared then the user 
can log on to the computer using any method. By default the option is 
disabled. 

Account is trusted for 
delegation 

If enabled,  allows a service running under this account to perform 
operations on behalf of other user accounts. By default, this option is 
enabled. 

Account is sensitive and 
cannot be delegated 

You can use this option if the account is a temporary account and 
cannot be assigned for delegation by another account. 

Use DES encryption 
types for this account 

Provides support for the Data Encryption Standard and depends on the 
level of encryption being used by your organization. 

Do not require 
Kerberos pre-
authentication 

Enable this option if the user does not require identity authentication. 
By default this option is disabled. It is advised that this option should 
be used with caution as enabling this option provides additional 
security. 

 
Profile 
 
Use this page to configure the user profile environment when a user remotely connects to a terminal 
server and also to modify the Terminal Services Profile. The User and Terminal Services user profile 
that can be modified are: 
 

User / Terminal 
Profile Options 

Description 

Profile Path Use this option to set the complete profile path assigned to the user 
when the user connects to a terminal server. You must assign a 
separate Terminal Profile for the Terminal Services session.  

Logon Script Use this option to set the script path for the user. 
Local path Specify a path to a home folder to be used for the User and the 

Terminal Services sessions. The folder can be either a local folder or a 
network share. 

Connect and To Specify the drive and the profile path to connect to. 
 
Modifications made in the Terminal Profiles applies only to Terminal Services. You can also restrict the 
user from logging to other Terminal Server by selecting the corresponding check box option. 
 
Organization 
 
Use this page to set the organization details like Department and Company and User's title.  
 
To specify the user's manager: 

1. Click Change and then select the user's manager from the Select User dialog box. When you 
specify a manager, the user shows up as a direct report in the manager's account.  

2. Click OK to apply the changes. 
3. The Object name is displayed in a default format, which is the canonical name. 

 
Dial-in and Remote 
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Use this page to set the dial-in properties that are used allow or deny a connection attempt by a user. 
The properties that can be set are: 
 

Property Name Description 
Remote Access Permission 
(Dial-in or VPN)  

Use this property to set remote access permission to explicitly 
allow, deny, or determine through remote access policies. 

Verify Caller ID  
 

If this property is enabled, the server verifies the caller's phone 
number. If the caller's phone number does not match the 
configured phone number, the connection attempt fails. 

Callback Options  If this property enabled, the server calls the caller back 
(Always Callback to) during the connection process. The phone 
number that is used by the server is Set by Caller or the 
network administrator. 

Assign a Static IP Address  Use this property to assign a specific IP address to a user when 
a connection is made. 

Remote Options Use this option to configure remote control for the connection. 
Enable Remote Control Enable this property to remotely view or control a user's 

session. 
Require User's Permission Enable this property to seek permission to view or participate 

in the session. 
Level of Control Click View the User's session to specify that the user's session 

can be viewed only, or click Interact with the session to specify 
that the user's session can be actively controlled. 

 
Terminal Services 
 
You can use Terminal Services Configuration to configure per-connection settings on a terminal server. 
You can configure the following settings by using Terminal Services Configuration: 
 

Terminal Services 
Configuration 

Description 

Start the following program 
at log on 

Enable the option to configure an initial program for the 
connection. 

Program File Name Type the file name of the program that you want to start when 
the user logs on to the terminal server. 

Start in Type the working directory path for the program. 
Client Devices  Select the appropriate client devices as required   
Sessions Select the required options to End a Disconnected Session, set 

Active Session Limit and to set Idle Session Limit. 
Disconnect from session Enable the option to disconnect the user from the session. 
End Session  Enable the option to end the session and delete it from the 

server permanently. 
Allow Reconnection  
From any client Enable this option to allow the user to reconnect to a 

disconnected session from any computer. 
From Originating client only Enable this option to allow the user to reconnect to a 

disconnected session from only the client computer where the 
session originated. 
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Bulk User Management 

Active Directory Manager allows you to create and manage multiple user accounts in the Active 
Directory at a single attempt. You can import the user attributes from a single .CSV file while creating 
user accounts, and common configuration and  modifications like Enabling and Disabling the users, 
moving home folders, or resetting passwords can be performed with few mouse clicks, thereby 
minimizing your time and effort. It also allows you to manage multiple attributes of user accounts in 
just a single step. The module, allows you to manage the user accounts and the entire Active 
Directory efficiently. 
 
The common Active Directory management functions, administration and attribute changes that can 
be performed with ease are: 
 

 Enable/Disable/Delete/Move/Unlock Users 
 Modify Attributes for Multiple Users 
 Move Home Folder 
 Reset Passwords for Multiple Users 
 Manage Groups and Memberships 

 

Enable Users 

Use this option to enable multiple Active Directory users simultaneously. 
 
To enable multiple users:  
 

1. Select All Users > Bulk User Management > Enable Users. The Select Users dialog is 
displayed. 

2. Select the users to enable and click OK. Click Yes to confirm the action. 

Disable Users 

Use this option to disable multiple Active Directory users simultaneously. 
 
To disable multiple users:  
 

1. Select All Users > Bulk User Management > Disable Users. The Select Users dialog is 
displayed. 

2. Select the users to disable and click OK. Click Yes to confirm the action. 

Delete Users 

Use this option to delete multiple Active Directory users. 
 

1. Select All Users > Bulk User Management > Delete Users. The Select Users dialog is 
displayed. 

2. Select the users to delete and click OK. Click Yes to confirm the action. 
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Unlock Users 

Use this option to unlock multiple Active Directory users. 
 

1. Select All Users > Bulk User Management > Unlock Users. The Select Users dialog is 
displayed. 

2. Select the users to unlock and click OK. Click Yes to confirm the action. 

Move Users 

Use this option to move multiple Active Directory users to a different Container. 
 

1. Select All Users > Bulk User Management > Move Users. The Select Users dialog is 
displayed. 

2. Select the Users to move and select the Container to move to and click OK. Click Yes to 
confirm the action. 

 Move Home Folder 

Use this option to move Home Folder. 
 

1. Select All Users > Bulk User Management > Move Home Folder. The Move Home Folder 
dialog is displayed. 

2. In the Move Home Folder to text box specify the drive and the home folder name. 
3. In the Move Profile to text box specify the folder path and click OK. 

Reset Password 

As an administrator you can bulk reset password options with few mouse clicks, thereby avoiding 
multiple steps involved.  
 

1. Select All Users > Bulk User Management > Reset Password.  
2. In the Reset Password dialog, enter the new password and for security purpose it is 

recommended to select the option User must change password at next logon.  
3. If the user account is locked, you can unlock it by selecting the corresponding check box 

option. 
 

Add to Group 

Use this option to assign a Group to multiple users. 
 

 Select All Users > Bulk User Management > Add to Group. The Add Group list is 
displayed. Select the Group that you want to assign to the selected list of users, and click OK 
to save the changes. 

Remove from Group 

Use this option to remove list of users from a Group. 
 

 Select All Users > Bulk User Management > Remove from Group. Select the Group that 
you want to remove for the selected list of users, and click OK to save the changes.  

Set Primary Group 

Use this option to assign a Primary Group to multiple users. 
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 Select All Users > Bulk User Management > Set Primary Group.  Select the group that 

you want to set as the primary group for the selected list of users, and click OK to save the 
changes. 

View Group Membership 

Use this option to view group membership of multiple users. 
 

 Select All Users > Bulk User Management > View Group Membership. Select the userS 
from the list to view the group membership.  

 

Change Profile Attributes 

Use this option to bulk change the user profile attributes. 
 

 Select All Users > Bulk User Management > Change Profile Attributes. The Change 
Profile Attributes dialog is displayed. The following user profile attributes can be changed. 

 
User Profile Options Description 

Profile Path Specify the complete profile path.  
Logon Script Specify the script path for the Users. 
Local path Specify a path to a home folder to be used for the 

Users 
Connect and To Specify the drive and the profile path to connect 

to. 
 

Change Contact Attributes  

Use this option to bulk change the user contact attributes. 
 

 Select All Users > Bulk User Management > Change Contact Attributes. The Contact 
Attributes dialog is displayed. Change the attributes as required and click OK to save the 
changes. 

 

Change Address Attributes 

Use this option to bulk change the user address attributes. 
 

 Select All Users > Bulk User Management > Change Address Attributes. The Address 
Attributes dialog is displayed. Change the attributes as required and click OK to save the 
changes. 

Manage User Workstation 

Use this option to manage user workstation. 
 

 Select All Users > Bulk User Management > Manage User Workstation. The Logon To 
 dialog is displayed. Add or remove computers as required and click OK to save the changes. 
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Filter Users 

Filtering the user list helps you manage the list more efficiently. You can choose to view a list of only 
those users whose name begins with a certain alphabet. 
 
To filter users: 
 

1. Select All Users > Apply Filter. The Filter dialog is displayed. In this example, create a 
filter designed to retrieve users whose name begins with the alphabet a.  

 

 
 

2. Under Select Condition, select the radio button Starts With and type 'a' in the text box and 
click OK, to display an alphabetically filtered list of users whose name begins with 'a'. Show 
All displays the complete list.  

 
 
 



34 

  

 

Stellar  
Active Directory Manager 
 

Export Users 

Active Directory holds valuable organizational information. This information can be very useful from an 
administrative point of view. Using the below mentioned options, you can extract and store 
information about specific users in a .CSV format for future use. The Export options are: 

Export Users to .CSV File 

This option allows you to export a blank user template that contains standard user attribute values, 
which can be applied while creating bulk users. The two export options are: 
 
Export Blank User Template 
 
To  Export Blank User Template: 
 

1. Select Export Users to .CSV File > Export Blank User Template.  
2. In the Import/Export file path dialog, Browse to select the file path, and click OK to complete 

the process.  
3. After the blank template is created successfully, a corresponding message is displayed. 

 

 
 
 

 

The blank template created, is used to add users manually. You cannot import 
users to the blank template.  

 
Export Users 
 
To export users: 
 

1. From the middle panel, select All Users >  Export Users to .CSV File > Export Users.  
2. In the Import/Export File Path dialog, specify the .csv file path to export the users.  
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3. Click OK to continue with the export process.  
4. From the Select Users list, choose the users to export. 

 

 
 

5. Click OK to continue. After the users are exported successfully, a corresponding message is 
displayed.  

The users are exported along with their properties. The exported users can be restored later as 
required. 
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Import Users 

Active Directory Manager provides you the flexibility to import user details from a .CSV file. The .CSV 
file should contain the attribute names as defined in the Active Directory. 
 
To Import Users: 
 

1. Select All Users > Import Users from .CSV File. 
2. In the Import/Export file path dialog type the .csv file path or Browse to select the file. 

 

 
 

3. From the Select Users to Import list, choose the users to import from the .CSV file. 
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After the successful import of the users, a corresponding message is displayed. The imported users 
are displayed in the hierarchy as normal users. 
 
 

 

It is advised, that you carry out the import process cautiously as 
duplicate user names if any, will be replaced. It means if a user name 
already exists in AD then it will be replaced by the new imported user 
with the same name.  
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Cleaning up Users 

Over a period of time, User accounts become obsolete and needs elimination. With Active Directory 
Manager you can trace all the inactive, disabled, account-expired users in Active Directory. If your 
organization uses an Active Directory housekeeping policy, you must follow it to clean up the users. 
The cleaning up process enhances the performance of your Active Directory.   
 
To clean users: 
 

1. Select Active Directory > Clean up. The Clean Up dialog is displayed.    
 

 
 

2. From the Select Object option choose Users. 
3. From Select Days and Type option, choose the number of days the user has been Inactive 

For. To narrow down the result further, select Exclude Never Logon to omit the display of 
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users who never logged on to any computer and select Exclude Disabled, to exclude the 
disabled user names in the result. 

4. Choose Select All to Delete or Disable the user accounts. 
5. After deleting or disabling the user accounts click OK. 
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Group Management 

Managing Active Directory Groups is a tedious task for most Active Directory administrators, as it 
requires time and effort. Configuring groups and assigning various group attributes is a complex 
procedure and involves multiple steps even to achieve simple tasks. Active Directory Manager eases 
the otherwise complicated task of managing Active Directory Groups. The two important aspects of 
Group Management are: 
 

 Create New Group 
 Bulk Group Management 
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Create a New Group 

Creating new groups in Active Directory is accomplished in much the same manner as creating a new 
user or a new OU. After creating the group, you can manage its memberships. 
 
To create a new group: 

1. Double-click Groups in the left panel.  
2. In the middle panel, select Active Directory > Global Groups > New Group. The Create 

New Group dialog is displayed. 

 
 

3. Type the Group Name. The name specified in this field is automatically populated in Group 
Name (Pre-Windows 2000).  

4. Select a Group Scope - Global. The group scope establishes where the group can be used and 
what types of objects it can contain. There are three options for Group Scope:  

5. Domain Local - a domain local group can only be used within a single domain. A domain local 
group can have users, global groups and universal groups as members.  

6. Global - a global group can be used throughout a domain tree, that is, the current domain and 
all child domains. A global group can have users and other global groups as members.  

7. Universal Group - a universal group can be used anywhere and can have users, global groups 
and other universal groups as members. 

5. Select a Group Type. The group type establishes what services can be applied to the group. 
There are two options for Group Type.  

• Security -  A security group is used to assign permissions to network resources. 
• Distribution -  The Distribution group is used for e-mail distribution lists or for grouping 

purposes.  
6. Click Create to create the new defined group. After the group is created successfully, a 

corresponding message is displayed. 
7. The new group is added under the Global Groups in the middle panel as displayed in the 

following illustration. 
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Single Group Properties 

After creating a group, you can define its properties to match your requirements. 
 
To view, modify or define group properties:  
 

 Select Group > Properties. The selected Group Properties dialog is displayed. The illustration 
below displays the properties for a group called 'rest'.  

 

 
 
 
The various group properties are: 
 
General 
 
Use this option to view and modify the General options of the group.  
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General Options Description 
Group Name (Pre-
Windows 2000) 

It is the Group name. 

Description It is the description of the Group. 
E-mail It is the E-mail id of the Group. 
Group Scope Select the Group Scope from the available options. The options 

available are: 
Domain Local  A domain local group can only be used within a single domain. A 

domain local group can have users, global groups and universal 
groups as members. 

Global A global group can be used throughout a domain tree, that is, the 
current domain and all child domains. A global group can have users 
and other global groups as members.  

Universal A universal group can be used anywhere and can have users, global 
groups and other universal groups as members. 

Group Type Select a Group Type. The options available are:  
Security A security group is used to assign permissions to network resources. 
Distribution Select the Distribution option if you intend to use the group for e-mail 

distribution lists or for grouping purposes. The primary purpose of this 
type of group is to group relate objects together.  

Notes Use this option to write group specific comments or notes. 
 
Members 
 
Displays the list of members of the group. You can Add more members or remove members as 
required. The list displays the Member Name and the complete folder Path.  
 
Member Of 
 
The list displays groups from the current domain and groups that are maintained in the global Catalog, 
for example, the Universal Groups.  
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Managed By 
 
Displays the Administrator details. The details can be changed as required. Select the option Manager 
can update membership list to enable the Manager to update the list. 
   
Object 
 
Displays the complete object details like the Canonical Object Name, Path, Category and the Object 
Class. 
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Single Group Management 

The Active Directory Manager helps the administrator to modify group attributes, rename group, move 
group to another container, etc.  
 
In left panel select the group created and right-click to view the available options to manage the 
group. 

Copying a Group 

Use this option to copy a selected group to another container. To copy a group: 
 

1. Select Group > Copy. The Copy Group dialog is displayed. 
2. Browse to selection the location to copy the Group and assign a group Name. 
3. Click OK to copy the group. If the operation is successful a corresponding message is 

displayed. 
 

Moving a Group 

Use this option to move a group from the current container to another container. 
 Select Group > Move.  Select the container to which you want to move the Group. 

 

Renaming a Group 

Use this option to remotely rename a user in any domain.  
 

 Select Groups > Group Name > Rename. In Rename Group dialog enter the Common Name 
and Pre-Windows 2000 Name  and click OK to save the changes. 

Deleting a Group 

Use this option to remotely delete a Group.  
 

 Select Groups > Group Name > Delete. Click Yes to confirm the action. 
 

Adding Member to Group 

To add a member to a Group: 
 

1. Select Groups > Group Name > Add Member.  
2. From the Select Member list, choose the member to add to the group and click OK 

Removing a Member 
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To remove a member from the Group: 
 

1. Select Groups > Group Name > Remove Member.  
2. From the Select Member list, choose the member to remove and click OK 

Copying to Server 

To copy a group to another computer: 
1. Select Groups > Group Name > Copy to Server.  
2. In the Copy Group to other Computer dialog, click Find to select the computer to copy the 

Group and click OK.  
 

Copying Members to Group 

To copy members to the Group: 
 

1. Select Groups > Group Name > Copy Members to Group.  
2. In the Copy Member to Group dialog, type the Group name and click OK. 
3. Select the members to copy and click OK. 

 

 
 

Viewing Group Details 

To view details of the group:  
 

 Select Groups > Group Name > View Group Details.  The group details are displayed in the 
right panel as illustrated below. 
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Viewing Group Members 

To view direct members: 
 

1. Select Groups > Group Name > View Group Members> View Direct Members Only. 
2. The Direct Group Members list is displayed in the right panel.  

 
To view all members: 
 

1. Select Groups > Group Name > View Group Members > View All Members. 
2. The list displays all the members in the Group in the right panel. 

 

Viewing Group Permissions 

To view the permissions of the selected group: 
 Select Groups > Group Name > Permissions. The permissions are displayed in the right 

panel. 
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Filter Groups 

Filter groups is similar to filtering the users. Filtering the group list helps you manage the list more 
efficiently. You can choose to view an alphabetically filtered list or the complete list of groups.  
 
To filter groups: 
 

1. Select All Groups > Apply Filter. The Filter dialog is displayed. In this example, create a 
filter designed to retrieve groups whose name begins with the alphabet w.  

 

 
 

2. Under Select Condition, select the radio button Starts With and type 'w' in the text box and 
click OK, to display an alphabetically filtered list of groups whose name begins with 'w'. Show 
All displays the complete list.  
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Bulk Group Management 

Bulk Group Management allows you to add members, remove members from the selected groups, 
move groups to a different container, view group memberships, delete groups, copy groups to a 
server and copy members from a single group to multiple groups. 

Adding Members to Group 

To add members to Groups: 
 

1. Select Global Groups > Bulk Group Management > Add Members.  
2. From the Select Groups list, choose one or more groups and click OK 

 

 
 

Removing Members from Groups 

To remove members from Groups: 
 

1. Select Global Groups > Bulk Group Management > Remove Members.  
2. From the Select Groups list, choose one or more groups and click OK. 
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Moving Groups 

To move groups from one container to another:  
 

1. Select Global Groups > Bulk Group Management > Move.  
2. From the Select Groups list, choose one or more groups to move and click OK 
3. From the Select Container list, select the container where you want to move the selected 

groups and click OK. 
 

Viewing Group Membership 

To view direct group members: 
 

1. Select Global Groups > Bulk Group Management > View Group Members > View Direct 
Group Members Only. 

2. The Direct Groups Members list is displayed.  Click OK to exit the list. 
 
To view all members: 
 

1. Select Global Groups > Bulk Group Management > View Group Members > View All 
Members. 

2. The list displays all the members in the Group. Click OK to exit the list. 
 

Deleting Groups 

Use this option to delete groups in bulk. 
 
To delete groups in bulk: 
 

1. Select Global Groups > Bulk Group Management > Delete Groups. 
2. From the Select Group dialog, select the groups to delete and click OK. 
3. When prompted to confirm deletion, click Yes. 

 

Copying Groups to Server 

Use this option to copy selected groups to a different server without affecting the original groups. 
 
To copy groups to the Server: 
 

1. Select Global Groups > Bulk Group Management > Copy to Server. 
2. From the Select Groups dialog, select the groups to copy to the Server and click OK. 
3. In the Copy Group to other Computer dialog, enter the target server name and click OK. 
4. You will be prompted to enter the login credentials. Type the details and click OK.  

 
 

Copying Members to multiple groups 

Use this option to copy single group members to multiple groups. 
 
To copy members to multiple groups: 
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1. Select Global Groups > Bulk Group Management > Copy Members to Multiple Groups. 
2. From the Select Group to Copy Members dialog, select the group to copy the members and 

click OK. 
3. In the Select Group dialog, select multiple groups where you want to copy the members and 

click OK. 
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Restoring Deleted Objects 

All the deleted Active Directory objects are listed under Deleted Objects in the left panel. Selecting 
Deleted Objects in the left panel expands the list in the middle panel and displayed under Deleted 
Groups as illustrated below. 
 

 
 
 
In Active Directory Manager, you can restore all the deleted objects if required.  
 
To restore deleted objects: 
 

1. Select Active Directory > Deleted Objects > Deleted Groups, right-click and select the 
RestoreAll option.  

2. The deleted objects will be restored in their original containers.  
 
You can also restore a single deleted object. For example, to restore a single deleted user: 
 

 Select the user to restore under Deleted Users, right-click and select Restore. 
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Computer Management 

Active Directory Manager allows you to manage computers in workgroup, current domain and remote 
domain by performing a number of tasks like move computers, enable, disable or add computers and 
modify their attributes, add jobs, install services, run queries and many other tasks on single and bulk 
computers.  
 
The Key features of Computer Management are: 
 

 Create New Computer 
 Single Computer Properties 
 Single Computer Management 
 Bulk Computer Management 
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Create New Computer 

With Active Directory Manager you can create one or more computers. Once the computer is created 
you can view and modify the different system properties. 
 
To create a new computer: 
 

1. Select Computers > New Computer. 
2. In the New Computer dialog, type a computer Name and specify the Path. The default path is 

set to Users. However, you can Browse and select a different path as well.  
 

 
 
You can perform various tasks on the new computer created, which is part of the workgroup, the 
current domain or a remote domain. 
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Single Computer Properties 

With Active Directory Manager you can view the different system properties. The property pages are 
used to view and modify the properties.  
 
To view the System Properties of the computer: 
 

 Select  <Computer Name> > Properties. The System Properties dialog is displayed. Each of 
the tabbed property page is described in detail subsequently. The System Properties are: 

 
Directory  
 

 
 
The Directory tab displays the following settings. 
 

Directory Settings Description 
Description It is the computer description. 
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Location  It is the computer location. 
Managed By Displays the manager details. 
Directory Path and 
Names 

These are system generated properties 
and cannot be modified. 

Pre Windows 2000 Displays the computer name. 
DNS Displays the DNS name 
DN Displays the DN name 
Path Displays the complete path 
Operating System  
OS Displays the operating system details 
Version Displays the OS version details 
SP Displays the service pack details. 

 
   
Object and Member of 
 
The Object and Member of tab displays the following details and each field is described in detail 
below. 
 

 
 
 
 

Object and Member 
of  Settings 

Description 

GUID Specify the globally unique identifier 
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(GUID). Every object stored in Active 
Directory is assigned a GUID and it never 
changes. 

SID Specify the Security Identifier of the 
computer. 

Created The date and time when the computer 
account was created. 

Modified The date and time when the computer 
account was modified. 

Category It is the object category and cannot be 
changed. 

Last Logon Specify the time that the user last logged 
into the domain. 

Logon Count It is the number of times the user logged 
in. 

Original USN It is the original identifier for controlling 
directory replication in Microsoft Windows 
2000. 

Current USN It is the current identifier for controlling 
directory replication in Microsoft Windows 
2000 

Member of  It displays a list of groups in the domain 
where the user's account is located 

 
Software  
 
The Software tab displays the Computer Name, Operating System and the list of software installed 
on the computer.  
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System  
 
The System tab displays the CPU information, logged on user detail like the User Name, Logon Server 
and Logon Domain, and other aspects of system information like the Property Name and the Value. 
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Environment  
 
The Environment tab displays the Property Name and Value of the available environment variables. 
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Network 
 
The Network tab displays the Network Transports, Network Card and other Network specifications as 
displayed in the illustration below and followed by the description of each field. 
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Property Name Description 
Network Transports Displays the transport name and address. 
DNS Host Name  Displays the DNS Host Name. 
DNS Domain Displays the DNS Domain name. 
Network Card 
Properties 

 

Network Cards Select the network card from the drop-
down list.  

DHCP Enabled If the option is enabled, this server 
protocol automatically provides an 
Internet Protocol (IP) host with its IP 
address and other related configuration 
information.  

DHCP Server It is the computer running the DHCP 
Server service that holds information 
about available IP addresses and related 
configuration information. 

IP Address and Subnet 
masks 

Displays the IP Address and the subnet 
masks. 

Gateway Servers Displays the Gateway Server address. 
WINS Servers Displays the IP address of the server on 

which WINS service is running. 
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DNS Servers Displays the IP address of the server on 
which DNS service is running. 

 
 
Dial-in  
The Dial-in tab displays the following details and is followed by the description of each field. 
 

 
 
 
 

Property Name Description 
Network Access 
Permission  

Use this property to set network access 
permission to explicitly allow, deny, or 
determine through network access 
policies. 

Verify Caller ID  
 

If this property is enabled, the server 
verifies the caller's phone number. If the 
caller's phone number does not match 
the configured phone number, the 
connection attempt fails. 

Callback Options  If this property is enabled, the server 
calls the caller back (Always Callback to) 
during the connection process. The 
phone number that is used by the server 
is Set by Caller or the network 
administrator. 
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Assign a Static IP Address  Use this property to assign a specific IP 
address to a user when a connection is 
made. 

Managed By Use this property to specify the 
Administrator details. 

Delegation Control  
Trust this computer for 
delegation 

If enabled, allows a service running 
under on this computer to perform 
operations on behalf of other servers. 
By default, this option is enabled. 
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Single Computer Management 

With Active Directory Manager, you can perform various tasks on one or more computers, which are 
part of the workgroup, current domain or a remote domain. 

Move Computer 

Use this option to move computers from one container to another just through few clicks and save 
your time. 
To move computers:  

1. Select <Computer Name> > Move Computer. The Select Container list is displayed. 
 

 
 

2. From the Select Containers list, select the container where you want to move the computer, 
and click OK.  

Disable Account 

Use this option to disable an account. 
 
To disable an account: 

1. Select <Computer Name> > Disable Account.  
2. An alert message is displayed, click Yes to confirm. A corresponding message confirms that 

the Computer account has been disabled. 

Delete  
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Use this option to delete the computer. 
 
To delete a computer: 
 

1. Select <Computer Name> > Delete.  
2. You will be prompted to confirm the action. Click Yes to delete the computer. A corresponding 

successful deletion message is displayed. 

Add Computer to Group 

Use this option to add the selected computer to other groups for managing them efficiently.  
 
To add computer to Group:  

1. Select <Computer Name> > Add Computer to Group. The Select Group list is displayed. 
 

 
 

2. From the list select the group to which you want to add the computer, and click OK. 

Remove Computers from Group 

Use this option to remove the selected computer from other groups.  
 
To remove the selected computer from Group:  

1. Select <Computer Name> > Remove Computer from Group. 
2. From the Select Group list, select the group from which you want to remove the computer, 

and click OK. 

List Permissions 
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Use this option to list selected computer permissions.   
 
To list the permissions:  

1. Select <Computer Name> > List Permissions. 
2. The computer permissions are displayed in the right panel, as illustrated below. 

 

 

Send Message 

You can use this option to send message to other accounts only if the Messenger Services is enabled 
on the user and receiver computers. The message sent is displayed on the receiver's console. 
 
To send message: 
 

1. Select <Computer Name> > Send Message. The Send Message dialog is displayed.  
 

 
 

2. In the Send Message dialog, type the content and click OK. 
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Change Common Details of Computer 

Use this option to change the common details of the computer. 
 
To change the common details of the computer: 
 

1. Select <Computer Name> > Change Common Details of Computer. The  Modify Computer 
Attribute dialog is displayed. 

2. In the dialog you can select and modify attributes like Managed by, Location and Description 
of the computer and click OK to save the changes made.  
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Bulk Computer Management 

With Active Directory Manager, you can manage computers in bulk. As an administrator you can select 
one or more computers from the list of computers available and perform different operations on them 
as listed below: 
 
 

 Enable/Disable Computers 
 Move Computers 
 Remove from Domain 
 Add/Remove Computers to Group 
 Set Primary Group of Computers 
 Change Common Details of Computers 

 

Enable Computers 

Use this option to remotely enable multiple disabled computers. 
 
To enable computers: 

1. Select Computers > Bulk Computer Management > Enable Computers. The Computer List 
dialog is displayed. 

2. Select the computers to enable and click OK to save the changes and display the status 
report. 

Disable Computers 

Use this option to remotely disable multiple computers. 
 
To enable computers: 

1. Select Computers > Bulk Computer Management > Disable Computers. The Computer List 
dialog is displayed. 

2. Select the computers to disable and click OK to save the changes and display the status 
report. 

Move Computers 

Use this option to move computers from one container to another container. 
 
To move computers: 

1. Select Computers > Bulk Computer Management > Move Computers. The Computer List dialog 
is displayed. 

2. Select the computers to move and click OK. 
3. From the Select Container list, select the container to which you want to move the selected 

computers, and click OK to save the changes and display the status report.   

Remove from Domain  
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Use this option to remove multiple computers from a selected domain. 
 
To remove computers: 

1. Select Computers > Bulk Computer Management > Remove Computers. The Computer List 
dialog is displayed. 

2. Select the computers to remove and click OK.  
3. When prompted to confirm the removal, click OK. 

Add Computers to Group 

Use this option to add computers to a Group for improved management. 
 
To add computers to Group: 

1. Select Computers > Bulk Computer Management > Add Computers. The Computer List dialog 
is displayed. 

2. Select the computers to add and click OK.  
3. From the Group List, select the Group to which you want to add the computers and click OK to 

save the changes and display the status report. 

Remove Computers from Group 

Use this option to remove computers from a Group.  
 
To remove computers from a Group: 

1. Select Computers > Bulk Computer Management > Remove Computers. The Computer List 
dialog is displayed. 

2. Select the computers to remove and click OK.  
3. From the Members List, select the members to delete from the group and click OK to save the 

changes and display the status report. 

Set Primary Group of Computers 

Use this option to set the primary group of computers. 
 
To set the primary group of computers: 

1. Select Computers > Bulk Computer Management > Set Primary Group of Computers. The 
Computer List dialog is displayed. 

2. Select the computers for which you want to set the primary group and click OK. 
3. From the Group List, select the Group to assign as the primary group and click OK to save the 

changes and display the status report. 

Change Common Details of Computers 

Use this option to change the common details of computers. 
 
To change the common details of computers: 

1. Select Computers > Bulk Computer Management > Change Common Details of Computers. 
The Computer List dialog is displayed. 

2. Select the computers  to modify the common details and click OK. 
3. From the Modify Attribute List dialog, select the attributes to modify and click OK to save the 

changes and display the status report. 
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Computer Features 

SADM allows you to manage a local computer along with the domain computers. When you expand 
the computer node then you see following child nodes that help you manage the computer: 
 
 

 Account Policy 
 Audit Policy 
 Printers 
 Shares 
 DFS 
 Session 
 Services 
 Devices 
 Events 
 Disk Space 
 Performance 
 Scheduled Jobs 
 User Rights 
 Registry 
 WMI 
 Software 
 TCP Utilities 
 Shutdown and Restart 
 Remote Desktop 
 Manage Computers 
 Shared Folder 
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Account Policy 

All security policies are computer-based policies. Account policies are defined on computers, but they 
affect how user accounts can interact with the computer or domain. Account policies contain two 
subsets: 
 

 Password Policy - This security setting determines the period of time, in days that a password 
must be used before the user can change it or the system requires the user to change it. The 
policy also determines the least number of characters that the password may contain. 

 Account Lockout Policy - Account Lockout Policy determines what happens when a user enters 
a wrong password.  

 

  
 
 

Password Policy Description 
Password History  
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Don't Keep Password History Select this option if you do not want to keep 
password history. By default the password history 
is saved. 

Remember Password Enter the number of passwords that you want the 
computer to remember. 

Maximum Password age This security setting determines the period of time 
(in days) that a password can be used before the 
system requires the user to change it.  

Password Never Expires Select this option if you want to retain the 
password till you decide to reset. 

Password Expires in  Enter the number of days after which the 
password should be reset. If you set the value to 
'0', then it is equivalent to 'Password Never 
Expires'. 

Minimum Password Age This security setting determines the period of time 
(in days) that a password must be used before the 
user can change it.  If the maximum password age 
is set to 0, the minimum password age can be set 
to any value. 

Allow Changes immediately Select this option to reset password immediately 
as required. 

Allow Changes in Enter the number of days after which the 
password can be reset. 

Minimum Password Length This security setting determines the least number 
of characters that a password for a user account 
may contain. You can set any value, but ensure 
that it is not less than seven (7)  characters, or 
you can establish that no password is required by 
setting the number of characters to 0. 

Permit Blank Password Select this option if want to establish that no 
password is required. 

At least....Characters Enter the minimum length of the password. If the 
value is set to '0' then it is equivalent to 'Blank 
Password'. 

Account Lockout This security setting determines the number of 
minutes a locked-out account remains locked-out.  

No Account Lockout Select this option if you do not want the account 
to be locked-out. 

Lockout After Specify the number of bad logon attempts after 
which the account should be locked-out. 

Reset Count After.....Minutes This setting determines the number of minutes 
that should elapse, after a failed logon attempt, 
for the failed logon counter to be reset. 

Lockout Duration This security setting determines the number of 
minutes a locked-out account remains.  

Forever (Until Admin Unlock) Use this setting if you want the  locked-out 
account to remain locked-out before the 
administrator has to unlock the account explicitly. 
By default, this setting is disabled. 

Duration...Minutes This security setting determines the number of 
minutes a locked-out account remains locked-out. 

Forcibly disconnect remote 
users from server when logon 
hour expires  

Use this setting to forcibly disconnect remote 
users when their specific logon hour expires. 
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Audit Policy 

As an administrator you can establish an organizational computer system audit policy for information 
security. Configuring Audit policy settings that monitor the creation or modification of objects enables 
you to track potential security problems, helps to ensure user accountability, and provides evidence in 
the event of a security breach. You can specify whether to audit successes or failures for the specific 
access request to each user. The options for each of the audit settings are identical: 
 

 Enable Auditing: If this option is not selected, no audit event is generated for the associated 
action. 

 Success: An audit event is generated when the requested action succeeds.  
 Failure: An audit event is generated when the requested action fails. 

 
To configure the Audit Policy setting: 
 

1. From the left panel click Computers > <Computer Name>. The selected computer features are 
displayed in the middle panel.  

2. Select Audit Policy, the corresponding setting screen is displayed. There are nine different 
kinds of events for which you can specify Audit Policy settings as illustrated below. 

 

 
 

Events  Description 
Logon & Logoff Audit this to record each instance of a user logging 
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on to or logging off from another computer in which 
this computer is used to validate the account. 

File & Object Access Audit this to record when someone has used a file, 
folder, printer, or other object. 

Use of User Rights Audit this to record when someone accesses an 
Active Directory Domain Services object that has its 
own system access control list.  

User & Group 
Management 

 Audit this to record when someone has changed an 
account name, enabled or disabled an account, 
created or deleted an account, changed a password, 
or changed a user group. 

Security Policy 
Changes 

Audit this to record attempts to change local security 
policies and to see if someone has changed user 
rights assignments, auditing policies, or trust 
policies. 

Restart & Shutdown Audit this to record when someone has shut down or 
restarted the computer, or when a process or 
program tries to do something that it does not have 
permission to do. For example, if a malicious 
software attempts to change a setting on your 
computer without your permission, system event 
auditing would record it. 

Process Tracking Audit this to record when events such as program 
activation or a process exiting occurs. 

Privileged Logons Audit this to record when someone performs a user 
right. 

Directory Services 
Access 

Audit this to record when someone accesses an 
Active Directory Domain Services object that has its 
own system access control list. 
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Printers 

With Active Directory Manager, you can perform various tasks on a Printer.  
 
The Printers node in the middle panel, when expanded, displays all the printers that are installed on 
the computer in the right panel. SADM enables you to manage the local as well network printers on 
domain. You can perform various operations to manage printers. 
 
You can select the Printer and view the details in the right panel as displayed in the illustration below. 
 

 
 
You can perform the following tasks on a Printer. All tasks are self-explanatory. 
 

 Add a New Printer 
 Cancel Jobs 
 Pause 
 Resume 
 Open Printer 
 Print Test Page 
 Set Printer as Default 
 Print Server Properties 
 Printer Properties 
 Print Preference 
 Delete Printer Connection 
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Shares 

The Shares node enables you to view and manage all shared drives, folders and files on the local and 
remote computers. You can expand this node to view all the shared folders in the middle panel and 
further expand the listed folders to view their sub-folders and constituent files in the right panel.  
 

 
 

1. Right click the Shares node to display the share details in the right panel with the 
information, such as Name, Path, Access Mask, and Allow Maximum.  

2. You can select a share and perform the following tasks: 
 

• Open 
• Explore 
• Search 
• Create Shortcut 
• Map Network Drive 
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DFS 

The DFS node in the middle panel corresponds to the Distributed File System (DFS) root.  DFS, is a 
set of client and server services that helps to organize many distributed file shares into a distributed 
file system.  
 
To view the DFS details: 
 

 Click the DFS option and view the details like Name, Root, State and the Status in the right 
panel.  
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Session 

The Sessions node displays all the users connected to the system. Click the Sessions node to view 
the list of connected users in the right panel.  It displays the following information for the connected 
users: Transport Name, User Name, Active Time (in Seconds), and Client Type.  
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Services 

The Services node enables you to view and manage all the Windows services related to local and 
remote computers. You can use the configuration options available under this node to start or stop a 
service, delete a service, and perform all services configuration operations that you are authorized for. 
You can view all the services running on the computer in the right panel by clicking the Services 
node. SADM allows you to perform various operations on services. Right click the Services node in 
the middle panel, to view the functions that can be executed to manage services, as displayed in the 
illustration below. 
 
 

 
 
 
Following are the operations that you can perform to the manage services: 
 

 Change Start Mode 
 Manual 
 Automatic 
 Disabled 
 Start 
 Stop 
 Resume 
 Pause 
 Delete 
 Start 
 Interrogate Service Update on Service Manager 
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Devices 

When you click the Devices node in the middle panel, the right panel displays all the devices installed 
on a system as illustrated below. 
 

 
 
 
The device details displayed are- Name, Service, Description and Manufacturer.  
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Events 

Events log helps you to determine those conditions, which caused any error in the user system. It 
helps you to record important events like low memory conditions, restart operations, failing hard 
drive, etc. Events help save any big occurrence for data loss, disk damages, disk corruptions, OS 
errors etc. All events configured for auditing in the Audit Policy section are registered in Windows 
event logs and can be viewed by using the Events node in the middle panel.  
 
To view Events: 
 

1. Click the Events node. The Event Viewer is displayed. You can expand a node in the left panel 
to view various categories of events in the right list pane as illustrated below. You can double-
click each sub-node to view related events in the right list pane. 

 

 
 

2. Use the available menu options to manage the events as required. 
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Disk Space 

Under the Disk Space node, you can view the disk space available on the various hard disk drives 
installed on the computer. The Disk Space node displays the entire information related to the logical 
drives like Name, Drive Type, Description and Size. 
 
To view the Disk Space: 
 

1. Click the Disk Space node in the middle panel. The right panel displays all the available 
logical drives.  

 

 
 
 

2. You can select a drive and perform the following functions: Open, Explore, Search, Create 
Shortcut and Map Network Drive. 
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Performance 

Active Directory Manager helps to view performance counters of operating system functioning, 
applications, services, or drivers. Data received from performance helps to identify and resolve 
problems, functioning, and performance of the applications for a computer. You can also view 
performance object and counters of remote domain and manage them. 
 
To view the performance: 
 

1. Click or expand the Performance node to view all the objects to be analyzed for a computer in 
the middle panel. 

 

 
 

2. Double-click any performance object name to view its respective performance counters in the 
right panel. 
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Scheduled Jobs 

The Scheduled Jobs node displays the scheduled Windows jobs. 
 
To view the Scheduled Jobs: 
 

 Click the Scheduled Jobs node in the middle panel. The Windows jobs are displayed in the 
right panel as illustrated below: 

 

 
 
Scheduled jobs can be configured by right clicking any of the jobs displayed in the right panel and 
selecting the appropriate option. The options available are: 
 

 Properties 
 Add New Job (AT) 
 Add New Job (Task) 
 Delete Selected Job 
 Run 
 Terminate 
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User Rights 

The User Rights node lists all the available user rights in the right panel as displayed in the 
illustration below. Each user rights node can be expanded to display all the users who have been 
granted that particular right. 
 

 
 
To assign more rights to a user: 
 

1. Select an object in the middle panel and right-click, choose Add Rights to add additional 
rights to an existing user. The Manage User Rights dialog is displayed. 
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2. From the Manage User Rights dialog, select the User or Group from the left dialog pane and 
click on Add. The selected User or Group is listed in the right dialog pane.  

3. From the drop-down list select the rights to assign to the selected User or Group.  
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Click OK to apply the rights and exit the dialog. 
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Registry 

You can view or modify software registries on a computer by clicking the Registry node in the middle 
panel.  
 
To view or modify a registry value:  
 

1. Click the Registry node in the middle panel to launch the Registry Editor as illustrated below.  
 

 
 
 

2. In the Registry Editor, use the left panel to browse the registry location.  
3. Double-click the registry file in the left panel to view the registry value name and registry 

value data. 
4. Make the required changes and click the OK button. 
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Window Management Instrumentation 

Windows Management Instrumentation (WMI) is a technology built into Windows that allows for 
improved manageability of computers in a networked environment. WMI is used to gather system 
statistics, monitor system health, and manage system components. Ensure that the service is running 
and properly configured for your environment. 
 
You can terminate a process or set different priorities for the processes. 
 

 
 
 
To terminate a process:  
 

 Select WMI in the middle panel and select the process in the right panel, right-click > 
Terminate. 

 
To set execution priorities of processes: 
 

 Select WMI in the middle panel and select the process in the right panel and right-click to 
display the menu options. The options are: 

 
• Real Time 
• High 
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• Above Normal 
• Normal 
• Below Normal 
• Low 
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Software 

The Software node displays details of the software installed on the computer.  
 
To display the software details: 
 

 Click the Software node in the middle panel. The right panel displays the software name and 
version as illustrated below. 
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TCP Utilities 

The TCP Utilities node lists the network utilities. The available utilities are Trace Route, Ping, Telnet, 
and FTP. 
 
Trace Route 
 
To use the Trace Route utility: 
 

1. Click TCP Utilities in the middle panel to expand the list. 
2. Click the Trace Route utility, the corresponding dialog box is displayed.  

 

 
 

3. Enter the following details: 
4. Target - It is the computer name. 
5. Maximum Hops - it is the maximum number of hops on the path. 
6. Timeout - Specifies the number of milliseconds to wait for each reply. 
7. Do not resolve address to host name -  Disables resolving IP addresses to host names. 
4. Click the Trace button to start. Click OK to exit the dialog. 

 
Ping 
 
Ping verifies configurations and tests IP connectivity. 
 
To use the Ping utility: 
 

1. Click the Ping utility in the middle panel, the corresponding dialog box is displayed. 
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2. The computer name to ping is populated in the Host text field. Select the number of Retries 
from the drop-down list. 

3. Click the Ping button. 
 
Telnet 
 
The Telnet utility uses terminal-based login to remotely access network devices that are running 
Telnet server software. 
 
To use the Telnet utility: 
 

 Click the Telnet utility in the middle panel. The tool starts the utility. Use the utility as 
required. 

 
FTP 
 
The FTP utility transfers files of any size between computers running Windows Server 2003 operating 
systems and any computer running File Transfer protocol server software.  
 
To use the FTP utility: 
 

 Click the FTP utility in the middle panel. The tool starts the utility. Use the utility as required. 
 



96 

  

 

Stellar  
Active Directory Manager 
 

Shutdown and Restart 

The Shutdown and the Restart features in the middle panel should be used cautiously to remotely 
shutdown or restart the destination computer. 
 
To shutdown the computer: 
 

 Click the Shutdown option in the middle panel. Click Yes when prompted to confirm. 
 
To restart the computer: 
 

 Click the Restart option in the middle panel. Click Yes when prompted to confirm. 
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Remote Desktop 

You can use the Remote Desktop option to connect to another computer on the network. Ensure that 
you have the required credentials to connect to the remote computer.  
 
To connect to remote desktop: 
 

 Click the Remote Desktop option, and type the password to connect to the target computer. 
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Manage Computers 

You can use the Computer Management option to manage other computers on the net. 
 
To manage computers: 
 

 Click the Manage Computers option in the middle panel. The Computer Management screen 
is displayed. Use the available options and utilities as required. 
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Shared Folder 

You can use the Shared Folder option to view and manage all the shared folders on the local 
computer. 
 
To view and manage the Shared Folders: 
 

 Click the Shared Folder option in the middle panel, the corresponding screen is displayed. 
Manage the folders as required. 
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Domain Controllers 

You can use ADM tool to view and manage various types of domain controllers. The tool provides 
many options to manage the DC, which in a normal scenario takes more time in administering. On 
expanding the Domain Controllers node, you can view all the controllers configured as domain 
controllers. The domain functions are the same as that of the Computer functions.  
 
The tool provides the following functions for a DC: 
 

 Account Policy 
 Audit Policy 
 Printers 
 Shares 
 DFS 
 Session 
 Services 
 Devices 
 Events 
 Disk Space 
 Performance 
 Scheduled Jobs 
 User Rights 
 Registry 
 WMI 
 Software 
 TCP Utilities 
 Shutdown and Restart 
 Remote Desktop 
 Manage Computers 
 Shared Folder 
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Cleaning up Computers 

Over a period of time, Computer accounts become obsolete and needs elimination. With Active 
Directory Manager you can trace all the inactive, disabled, account-expired computers in Active 
Directory. If your organization has an Active Directory housekeeping policy, follow it to clean up the 
computers. The cleaning up process enhances the performance of your Active Directory.   
 
To clean computers: 
 

1. Select Active Directory > Clean up. The Clean Up dialog is displayed.    
 

 
 

2. From the Select Object option choose Computers. 
3. From Select Days and Type option choose the number of days the computer has been 

Inactive For. To narrow down the result further, select Exclude Never Logon to omit the 
display of computers that has never been logged on to and select Exclude Disabled, to exclude 
the disabled computer names in the result. 

4. Choose Select All to Delete or Disable the computer accounts. 
5. After deleting or disabling the computer accounts click OK. 
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Group Policy Management 

Group Policy objects play a powerful role in how the network is managed and secured. As an 
administrator you can manage user settings on multiple computers at once, thus every change to 
Group Policy affects multiple users and computers. You can use Group Policy to specify options for 
groups of computers and users. With Active Directory you can enable or disable all the required GPOs 
in any domain completely or partially. You can also enforce group policies, link group policies or 
remove links. 
 
This section includes: 
 

 Enable or Disable Group Policy Settings 
 Link Group Policies 
 Enforce Group Policies 
 Disable GPO Links 
 Remove Links 
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Enable or Disable Policy Settings 

Active Directory Manager helps administrators in managing the Group Policy Objects of selected 
domains. 
 
To enable or disable the GPOs: 
 

1. Go to File > GPO Management. The Group Policy Management screen is displayed. 
2. Choose Select All to select all the available GPOs. 

 

 
 
 
Enable 
 
With this feature, administrators can enable all the required GPOs in any domain completely or 
partially, with a single mouse-click instantly. The options available are: 
 
User Configuration Settings Only -  select this option to enable the GPO of user configuration settings 
alone. 



104 

Computer Configuration Settings Only - select this option to enable the GPO of computer configuration 
settings alone. 
Both Configuration Settings - select this option to enable the GPO of both the configuration settings. 
 
Disable 
 
With this feature, administrators can disable all the required GPOs in any domain completely or 
partially, with just a single mouse-click instantly. The options available are: 
 
User Configuration Settings Only -  select this option to disable the GPO of user configuration settings 
alone. 
Computer Configuration Settings Only - select this option to disable the GPO of computer configuration 
settings alone. 
Both Configuration Settings - select this option to disable the GPO of both the configuration settings. 
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Link Group Policies to OUs 

A Group Policy Object can be associated or linked to one or more Active Directory containers, such as 
a site, domain, or organizational unit. Multiple containers can be linked to the same GPO, and a single 
container can have more than one GPO linked to it. If multiple GPOs are linked to one container, you 
can prioritize the order in which the GPOs are applied. 
 
When you link GPOs to Active Directory containers, you can implement Group Policy settings for a 
broad or narrow portion of the organization, as required. 
 
To link group policies to OU: 
 

1. Go to File > GPO Management. The Group Policy Management screen is displayed.  In the left 
panel click the Group Policy Objects, to list all the GPOs available in the domain. 

2. Choose Select All to select all the available GPOs or click the check box against each GPO 
name to select individual GPOs.  

3. Click Link GPO. The Linked GPOs are listed in the right panel. The panel displays the selected 
GPO Name, its Link Status, Enforce Status and GPO Status.  

4. The right panel displays two tab options- Manage and Enforce. Click the down arrow on the 
Manage tab to display the three available link options as illustrated below. 
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3. Select Enable Links. The Select GPOs screen is displayed 
 

 
 

4. Select the GPOs for which you want to enable the link. You can either choose Select All option 
to enable the link for all the GPOs available in the list or you can choose individual GPO link to 
enable.  Click OK to save and return to the main screen. On the main screen, when the Link is 
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enabled, the Group Policy is linked to the OU, and the policy applies to the objects within the 
OU.  
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Enforce Group Policies 

The Group Policy Management allows you to enforce a GPO link. You can specify that the settings in a 
GPO link should take precedence over the settings of any child object by setting that link to Enforced. 
GPO-links that are enforced cannot be blocked from the parent container. With enforcement, the 
parent GPO link always has precedence. By default, GPO links are not enforced.  
 
To enforce a GPO link: 
 

1. Click the down arrow on the Enforce tab to display the two available options as illustrated 
below. 

 

 
 

3. Select Yes to enforce group policy. The Select GPOs screen is displayed. 
4. Select the GPOs. You can either choose Select All option to link all the GPOs available in the 

list or you can choose individual GPO link to enforce.  Click OK to save and return to the main 
screen. When the policy is enforced, the policy or more specifically its settings cannot be 
overwritten by a policy that is applied later. 
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Disable GPO Links 

You can disable GPO links if you no longer want the settings to apply to users and computers in the 
site, domain, or organizational unit and Active Directory containers.  
 
To disable a GPO link: 
 

1. Select Group Policy Objects. In the right panel click the down arrow on the Manage tab.  
2. Click Disable Links. From the Select GPOs list, choose the GPOs and click OK. 
3. After the links are disabled, a corresponding message is displayed.  
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Remove Links 

You can remove links to a GPO if you no longer want the links to exist in the Organizational Unit. 
 
To remove a GPO link: 
 

1. Select Group Policy Objects. In the right panel click the down arrow on the Manage tab.  
2. Click Remove Links. From the Select GPOs list, choose the GPOs and click OK. 
3. After the links are removed, a corresponding message is displayed. 
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Query Management 

Active Directory Manager supports a flexible search engine that is used to retrieve and display Active 
Directory information. You can use the Query Management option to retrieve information from All 
Users, All Groups objects and also from any of the containers.  You can create new queries with 
custom filters. The new queries are saved and displayed in the left panel under the corresponding 
containers.  
 
This section includes the following topics: 
 

 Create a New Query 
 Export a Query File 
 Import a Query File 
 View a Query 
 Delete a Query 

 
 



112 

 

 

Stellar  
Active Directory Manager 
 

Create New Query 

Active Directory Manager allows you to retrieve any attribute data User objects’ first name, last name 
telephone, address and other details, that you require from the Active Directory. The option also helps 
you to query Active Directory Group and Computer objects. A logical query creation enhances 
performance. 
 
 

 

The query created in this section will be used as a reference for all the related 
query management options. In this section we will create a query and assign a 
Name - add and query it on the Object Users, to display all names that begin 
with the alphabet a.  

 
To create a new query: 
 

1. Select File > Query Manager. The Query Manager displays four options as illustrated below: 
 

 
 

2. Click the New Query option, the corresponding dialog is displayed. The illustration below 
displays the list of objects on which you can base your query. 
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2. Type a name for the query in the Query Name field.  
3. To Query for Object, select the specific object from the drop-down list. 
4. Specify the Field Name to query. 
5. Apply the Conditions and Value for the query filter and click Add. 
6. You can add more Field Names and Conditions to narrow down the query result. The query 

Field Name, Condition and Value are displayed in the lower panel. 
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7. Click OK to save the query. The Query created and saved is displayed in the left pane as 
illustrated below. 
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View Query 

All the queries that you create and save are listed in the left panel under Saved Query. You can view 
individual saved queries as required.   
 
To view a saved query: 
 

1.  Under Saved Query, select <Query Name >, right-click and choose View Query. The View 
Query dialog is displayed. 

 

 
 

2. Click OK to exit the View Query screen. 
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Import a Query File 

This option allows you to import a saved query file from different computers or domains.  
 
To import a saved query file: 
 

1. From the File menu options click Query Manager > Import Query File.  
 

 
 

2. From the Import File dialog, Browse to select the query file residing on a different computer or 
domain controller. The query file name has a .ini extension.  Click Open, to import the 
 query file.   

3. A Successful Import alert is displayed. Click OK. The query imported from the file is listed 
under Saved Query of the current computer. 
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Export a Query File 

You can use the Export a Query File option, to export a saved query from the current computer or 
domain to another computer.  
 
To export a saved query: 
 

1. Select the query in the left panel under Saved Query. 
2. From the File menu options click Query Manager > Export Query File.  

 

 
 

2. From the Export File dialog, Browse to the query file and click Open. 
3. A Successful Export alert is displayed. Click OK. 
4. The exported query is displayed in the left panel under Saved Query of the computer or 

domain where you have exported the query file. 
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Executing a Query 

You can execute a saved query as required. 
 
To execute a saved query: 
 

1. In the left panel under Saved Query, double-click the query to execute. The middle panel 
displays the query name and the query result as illustrated below.   

 

 
 

2. In the above illustration, the saved query (add) executed, displayed the result - 
Administrator.  It means you defined a query to display the user names that starts with the 
alphabet a and Administrator is the only name found. If you select Administrator in the 
middle panel, the right panel will display the corresponding attributes as illustrated below. 
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Delete a Query 

This option allows you to delete saved queries from a computer. 
 
To delete a saved query: 
 

1. From the File menu options click Query Manager >  Delete All Query. This option will 
delete all the defined queries in the computer. 

2. When prompted to confirm deletion, click Yes to delete the queries. 
3. To delete a single query, select the query to delete under Saved Queries in the right panel, 

right-click and select Delete Query. 
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Container Management 

Containers or Organizational Units (OUs) are used in Windows AD to implement objects as logical 
business units, and are an important part of the Active Directory system. OUs in AD logically comprise 
AD objects including other OUs. The Containers/OUs node in the left tree panel can be expanded to 
display all user-defined and in-built OUs in the middle panel. Each OU can be further expanded to 
display all AD objects that are logically grouped under it. As an administrator you can create 
containers  for logical grouping and setting permissions. 
 
This section includes: 
 

 Creating Organizational Unit 
 Container Properties 
 Managing Containers 
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Create New Organizational Unit 

With Stellar Active Directory Manager, you can create an Active Directory Organizational Unit with a 
specific name in a specific Active Directory folder. 
 
To create an Organizational Unit: 
 

1. Select Active Directory > New > Organizational Unit. 
 

 
 

2. In the New Organization Unit dialog,  type the container Name. You can either create the OU 
in the default location or click Browse to select another location. Click Create to create the 
new container. 

3. The new container created is displayed in the middle panel under ACTIVEDIRECTORY as 
displayed in the following illustration. 
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4. After creating the container, you can Move, Rename, Delete the container or View Permissions 
and Properties.  

5. Double-click the new OU created to expand the tree. You will notice that the new OU created 
includes Users, inetOrgPerson,  Contacts, Computers, Groups, MSMQ Queue aliases, Shared 
folders and Printers as illustrated below. Except Shared Folders and Printers, you can create 
the other objects listed in the the new OU. You can only view the Shared Folders and the 
Printers. 

 

 
 
 
To add an object to the OU selected: 
 

6. Select New > <object name>. You can create one of the following objects:  
 Computer  
 Group  
 User  
 Contact  
 InetOrgPersons 
 MSMQ Alias 

 
7. Follow the on-screen instructions to create a new object in OU. 
8. When the process is completed, a new object appears in the selected container/OU as a child 

node in the middle panel. 
9. You can select each object created in the middle panel to view the details in the right panel. 
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Container Properties 

With  Active Directory Manager, you can set and change the following properties of Organizational 
Units: 
 

 Description 
 Street 
 City 
 State/province 
 Zip/Postal Code 
 Country/region 
 [Managed By] Name 

 
The Object Info. section displays the Object details and USNs.  
 
To view and change the Organizational Unit properties: 
 

1. Select OU Name > Properties. The OU Properties dialog is displayed. 
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2. In the OU Properties dialog, you can modify the General Info and the Managed By fields. Make 
changes as required and click OK to save the changes. None of the editable properties affects 
the way Windows work. 
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Managing Containers 

You can manage the containers by performing various operations as listed below: 
 

 Moving a Container 
 Renaming a Container 
 Deleting a Container 
 Viewing Permissions 

 

Moving a Container 

Use this option to move a container.  
 

1. To move the container,  right-click the organizational unit and select Move. 
2. In the Select Container list click the folder to which you want to move the organizational unit 

and click OK. 
 

 
 

Renaming a Container  

Use this option to rename the container. 
 

1. To rename the container, right-click the organizational unit and select Rename. 
2. In the Rename OU dialog, type the New Name and click OK to save the changes. 
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Deleting a Container 

Use this option to delete a selected container. 
 

 To delete the container, right-click the organizational unit and select Delete. Click Yes to 
confirm.   

 

Viewing Permissions 

Use this option to view container permissions. 
 

 To view the container permissions, right-click the organizational unit and select Permissions. 
The Permissions are displayed in the right panel. 
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Reports 

Active Directory Manager provide you with a number of report for you to assess and analyze the user 
account, groups, OUs & GPOs, printers, contacts, event logs and other details of your Active Directory. 
To work with reports, you need to familiarize yourself with the following buttons of the software: 
 

Button Description 
Save Use this option to save the generated report in either of the four formats - XLS, 

CSV, PDF or HTML. 
Once you click this option, 
 Select a format type (either XLS, CSV, PDF or HTML) from Select Report 

Format dialog box. 
 Click OK. 
 Browse to a desired location to save the report and click Save. 
 Click OK again. 

Print Use this option to print a hard copy of the generated report. 
Once you click this option, 
Click Yes. 
Select a printer from Print dialog box. 
Click OK. 

Print 
Preview 

Use this option to preview the report before saving or printing it. 

Help Use this option to access Active Directory Manager user manual. 
 
This section includes the following topics: 
 

 User Reports 
 Group Reports 
 OU & GPO Reports 
 NTFS Reports 
 Exchange Reports 

 Other User 
Reports 

 Computer Reports 
 Contact Reports 
 Printer Reports 
 Event Log Reports 

 



129 

  

 

Stellar  
Active Directory Manager 
 

User Reports 

User Reports option of Stellar Active Directory Reporting module allows you to view user reports of a 
domain. 
 
The different user reports you can view, are as follows: 
 

Report Option Description 
All Users This option lists all the users which exist on a domain. 
Enable Users This option lists all those users which are enabled on a 

domain. 
Disable Users This option lists all those users which are disabled on a 

domain. 
Inactive Users This option, by default, lists all the users of a domain 

which are inactive for last 30 days.* 
Users in a group This option lists those users who exist in a specified 

group of a domain. 
Once you choose this option, 
 Select Group dialog box will open. 
 Select a group from the Select group from list 

section. 
 Click OK. 

Users With Logon Script This option lists those users who are assigned a logon 
script. 

Users Without Logout Script This option lists those users who have not been 
assigned a logon script. 

Dial in Allow Access This option lists those users who are assigned a dial in 
access. 

Dial in Deny Access This option lists those users who have been denied a 
dial in access. 

Recently Modified Users This option, by default, lists those user accounts which 
have been modified in last 30 days.* 

Recently Created Users This option, by default, lists those user accounts which 
have been created in last 30 days.* 

Recently Deleted Users This option, by default, lists those user accounts which 
have been deleted in last 30 days.* 

Users With Empty Attributes This option lists those users on whom the empty 
attributes criteria is applicable. 
Once you choose this option, 
 Select Empty Attributes dialog box will open. 
 Select either Match Selected Attributes (All) or 

Match Selected Attributes (Anyone) radio option. 
 To select an attribute / column head, select an 

attribute from Available Attributes column and click 
on Add Columns button. The attribute will move to 
Selected Attributes column. 

 To remove an attribute / column head, select an 
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attribute from Selected Attributes column and click 
on Remove Columns button. The attribute will 
move to Available Attribute column. 

 Click OK. 
Users Without Managers This option lists those users accounts which are not 

managed by a manager in the domain. 
Manager Based Users This option lists those users accounts which are 

managed by a manager in the domain. 
Users in More than One Group This option lists those users who are members of two 

or more groups. 
 

 

*By default, a report will be generated for a period of thirty days. You can 
customize a report by changing the number of days in Enter the no. of days 
field and clicking Generate, to view a report for the specified number of days. 

 
To view User Reports: 
 

1. On Stellar Active Directory Reporting screen, select User Reports. 
2. On next screen, under User Reports, click on the appropriate option (listed above) and the 

application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
4. To select an attribute / column head, in Column Customization dialog box, select an 

attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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Group Reports 

Group Reports option of Stellar Active Directory Reporting module allows you to view group reports of 
a domain. 
 
The different group reports you can view, are as follows: 
 

Report Option Description 
All Groups This option lists all the existing groups of a domain. 
Global Groups This option lists all the global groups of a domain. 
Local Groups This option lists all the local groups of a domain.  
Universal Groups This option lists all the universal groups of a domain. 
Groups Type and Scope This option lists the groups of a domain as per group type and 

group scope. 
Once you choose this option, 
 Search Setting for Groups dialog box will open. 
 Select a group scope (Global, Local or Universal) and 

group type (Security or Distribution) to filter the report. 
 Click OK. 

Managed Groups This option lists groups which are managed in a domain. 
UnManaged Groups This option lists the groups which are not managed in a 

domain. 
Top Big Groups This option lists the groups in a hierarchical manner, which 

rank higher in its member count than other groups in domain.  
Once you choose this option, 
 List Groups With Highest Members dialog box will open. 
 Enter a number in Enter a number to list top big groups in 

a domain: field, in Search Group section. 
 Click OK. 

Groups without 
Members 

This option lists all the groups of the domain which do not have 
any members. 

Group Members in a 
User 

This option lists the group(s) in which a (selected) user is a 
member of.  
Once you choose this option, 
 Select User dialog box will open. 
 Select a user from the Select User from List section. 
 Click OK. 

Security Groups This option lists the security groups of a domain 
Distribution Groups This option lists the distribution groups of a domain. 

 
To view Group Reports: 
 

1. On Stellar Active Directory Reporting screen, select Group Reports. 
2. On next screen, under Group Reports, click on the appropriate option (listed above) and the 

application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
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4. To select an attribute / column head, in Column Customization dialog box, select an 
attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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OU & GPO Reports 

OU & GPO Reports option of Stellar Active Directory Reporting module allows you to view OU 
(Organizational Unit) and GPO (Group Policy Object) reports of a domain. 
 
The different OU & GPO reports you can view, are as follows: 
 

Report Option Description 
Organizational Unit 
All OUs This option lists all OUs present in a domain. 
Empty OUs This option lists all the empty OUs in a domain. 
GPO Linked OUs This option lists OUs that are linked with GPO (Group Policy 

Objects). Report is generated for existing OUs of a selected 
domain. 

GPO Blocked 
Inheritance OUs 

This option lists OUs whose GPOs are blocked from 
inheritance. 

Recently Modified OUs This option, by default, lists those OUs which have been 
modified in last 30 days.* 

Recently Created OUs This option, by default, lists those OUs which have been 
created in last 30 days.* 

User Only OUs This option lists OUs that contain only users. Report is 
generated only for existing OUs of a domain. 

Computer Only OUs This option lists OUs that contain only computers. Report is 
generated only for existing OUs of a domain. 

Group Policy Objects Report 
All GPOs This option lists all GPOs present in active directory. 
Disabled GPOs This option lists all GPOs which are disabled. Report will list 

GPOs with either computer or user configuration setting are 
disabled or both.  

Unused GPOs This option lists GPOs which are not in use since they were 
linked to a GPO. 

Recently Created GPOs This option, by default, lists GPOs which were created in last 
30 days.* 

Recently Modified GPOs This option, by default, lists GPOs which were modified in last 
30 days.* 

Frequently Modified 
Computer Setting GPOs 

This option lists GPOs with frequently modified computer 
settings. 

Frequently Modified 
User Setting GPOs 

This option lists GPOs with frequently modified user settings. 

Domain Linked GPOs This option lists GPOs which are linked to a domain. 
OU Linked GPOs This option lists GPOs which are linked with any OUs.  
Site Linked GPOs This option lists GPOs which are linked with any site. 
GPO Blocked 
Inheritance Containers 

This option lists OUs whose inheritance is blocked. 

Computer Setting 
Disabled GPOs 

This option lists all GPOs with disabled computer settings. 
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User Setting Disabled 
GPOs 

This option lists all GPOs with disabled user settings. 

Frequently Modified 
GPOs 

This option lists all GPOs which are frequently modified. 

 

 

*By default, a report will be generated for a period of thirty days. You can 
customize a report by changing the number of days in Enter the no. of days 
field and clicking Generate, to view a report for the specified number of days. 

 
To view OU & GPO Reports: 
 

1. On Stellar Active Directory Reporting screen, select OU & GPO Reports. 
2. On next screen, under OU & GPO Reports, click on the appropriate option (listed above) and 

the application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
4. To select an attribute / column head, in Column Customization dialog box, select an 

attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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NTFS Reports 

NTFS Reports option of Stellar Active Directory Reporting module allows you to view different kinds of 
reports on folders (as per their access types and permissions) of the domain's computers. 
 
The different NTFS reports you can view, are as follows: 
 

Report Option Description 
All Share This option lists all the shared folders of a domain. 
Permission For Folders This option lists all the permissions of a shared folder of a 

domain's computer. 
Once you choose this option, 
 Select Folder For Permission dialog box will open. 
 Select the folder, whose permissions report you want to 

view. (Incase you want to view a particular sub folder's 
report, click on Get Subfolders button after selecting a 
folder.) 

 After selecting the necessary folder / sub folder, click 
OK. 

Non-Inheritable Folders This option lists all the folders which cannot be inherited. 
Once you choose this option, 
 Select Folder For Permission dialog box will open. 
 Select the folder, whose permissions report you want to 

view. (Incase you want to view a particular sub folder's 
report, click on Get Subfolders button after selecting a 
folder.) 

 After selecting the necessary folder / sub folder, click 
OK. 

Folder Accessible By 
Account 

This option will list all the permissions a user has on a 
particular folder / sub folder. 
Once you select this option, 
 Select Account and folder dialog box will open up. 
 Select an account type (Users, Groups, or All) from 

Choose Account Type section. 
 Select an user account from Select Account drop list. 
 Select a folder from Select Folder for Permission 

dialog box. (Incase you want to view a particular sub 
folder's report, click on Get Subfolders button after 
selecting a folder.) 

 Select access type (FullControl or AnyControl) from 
Access Type section. 

 
To view NTFS Reports: 
 

1. On Stellar Active Directory Reporting screen, select NTFS Reports. 
2. On next screen, under NTFS Reports, click on the appropriate option (listed above) and the 

application will display the corresponding report. 
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Exchange Reports 

Exchange Reports option of Stellar Active Directory Reporting module allows you to view Microsoft 
Exchange reports of a domain. 
 
The different exchange reports you can view, are as follows: 
 

Report Option Description 
General Report 
Mail Enabled Users This options lists users who are mail enabled. 

Mail enabled users are those who can receive 
messages only at an external mail address, they 
have no dedicated mail boxes in an exchange 
server but they are listed in the global address 
list. 

Mail-Box Enabled Users This options lists users who are Mail-Box 
enabled. Such users have a dedicated mail-box 
in the exchange server. 

Users Without Mail-Box This option lists users who do not have a 
dedicated Mail-box in the exchange server. 

Users With E-mail Proxy Enabled This options lists users whose proxy e-mails are 
enabled. Such users have proxy email 
addresses. 

Users With Filtered E-mail Proxy 
Enabled 

This options lists users whose proxy enabled e-
mails are filtered. 
Once you select this option, 
 Enter Proxy Address dialog box opens. 
 Enter the address you want to find. 
 Click OK. 

Mail Enabled Groups This option lists groups which are mail enabled. 
In such groups, emails can be sent to all the 
members of the group. 

Groups With E-mail Proxy Enabled This option lists all the groups of a domain who 
have proxy email addresses. 

Groups With Filtered E-mail Proxy 
Enabled 

This option lists groups whose proxy enabled e- 
mails are filtered. 
Once you select this option, 
 Enter Proxy Address dialog box opens. 
 Enter the address you want to find. 
 Click OK. 

Distribution List 
Distribution List Members This option lists contact and user details of users 

who are members of distribution lists of a 
domain. 

Non Distribution List Members This option lists contact and user details of users 
who are not members of any distribution lists in 
a domain.  
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Delivery Recipient Setting 
Users With Default Sending 
Message Size 

This option lists users who have a default limit 
on the size of emails they can send. 

Users With Restricted Sending 
Message Size 

This option lists users who have restrictions on 
the size of emails they can send. 

Users With Default Recipient Size This option lists users who have a default limit 
on the number of recipients they can send 
emails to.  

Users With Restricted Recipient 
Size 

This option lists users who have restrictions on 
number of recipients they can send emails to. 

Users With Default Receiving 
Message Size 

This option lists users who have a default size 
limit on the size of emails they receive. 

Users With Restricted Receiving 
Message Size 

This option lists users who have restrictions on 
the size of emails they receive. 

Users With Default Storage Limit This option lists users who have set the default 
limit for their Exchange storage mailbox size. 
Whenever a new mailbox is created, if no 
specific storage size is specified, then the default 
storage limit is applied on the mailbox. 

Users With MailBox Size Limit This option lists users who have limits set on 
their Exchange mailbox storage size. 

Users Hidden From Exchange 
Address List 

This option lists all users who are hidden from 
Exchange Address list. In some organizations, 
few email addresses are kept confidential and 
they are not listed in the global address list.   

Users Accept Messages From 
Everyone 

This option lists users who can accept messages 
from anyone and have no restriction on them in 
receiving emails. 

Users Based on ForwardTo This option lists users whose emails are 
forwarded to any specific user. 

Feature Based Report 
Users With POP3 Enabled This option lists all users who have enabled their 

POP3 feature. 
Users With POP3 Disabled This option lists all users who have disabled their 

POP3 feature. 
Users With OMA Enabled This option lists all users who have enabled their 

Outlook Mobile Access (OMA*) feature. Such 
users can access their Outlook accounts (& all its 
features) using a browser from mobile devices. 

Users With OMA Disabled This option lists all users who have disabled their 
Outlook Mobile Access (OMA*) feature. Such 
users will not be able to access their Outlook 
accounts using a browser from mobile devices. 

Users With OWA Enabled This option lists all users who have enabled their 
Outlook Web Access (OWA) feature. Such users 
can access their Outlook accounts (& all its 
features) using a any web browser. 

Users With OWA Disabled This option lists all users who have disabled their 
Outlook Web Access (OWA) feature. Such users 
will not be able to access their Outlook accounts 
using a web browser. 

Users With IMAP4 Enabled This option lists all users who have enabled their 
IMAP4 (Internet Mail Access Protocol v4) 
feature. 

Users With IMAP4 Disabled This option lists all users who have disabled their 
IMAP4 (Internet Mail Access Protocol v4) 
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feature. 
Active Sync Enabled Users This option lists all users who have enabled 

active synchronization feature. Using this 
feature, a user can automatically synchronize 
Outlook data with Microsoft Exchange server and 
their mobile devices. 

Active Sync Disabled Users This option lists all users who have disabled 
active synchronization feature. With this feature 
disabled, users will not be able to automatically 
synchronize Outlook data with Microsoft 
Exchange server and their mobile devices.  

 

 

*OMA feature is available in Microsoft Exchange Server 2003 only. 

 
To view Exchange Reports: 
 

1. On Stellar Active Directory Reporting screen, select Exchange Reports. 
2. On next screen, under Exchange Reports, click on the appropriate option (listed above) and 

the application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
4. To select an attribute / column head, in Column Customization dialog box, select an 

attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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Other User Reports 

Other User Reports option of Stellar Active Directory Reporting module allows you to view user reports 
of a domain.  
 
The different other user reports you can view, are as follows: 
 

Report Option Description 
Passwords Report 
Users Can't Change Password This option lists those users who cannot change 

their passwords.  
Users Whose Passwords Never Change This option lists those users whose passwords will 

never expire.  
Password Expired Users This option lists those user accounts whose 

passwords have expired.  
Soon-to-Expire Users Passwords This option, by default, lists those users whose 

passwords will expire in coming 30 days.* 
Password Changed Users This option, by default, lists those users who have 

changed their passwords in last 30 days.* 
Password Unchanged Users This option, by default, lists those users who have 

not changed their passwords in last 30 days.* 
Users Must Change Password at Next 
Logon 

This option will list users who will have to change 
their passwords at next login. 

Accounts Report 
Recently Account Expired Users This option, by default, lists those users whose 

accounts have expired in last 30 days.* 
Soon-to-Expire User Accounts This option, by default, lists those users whose 

accounts will expire in coming 30 days.* 
Account Never Expire Users This option lists those users whose accounts will 

never expire in the domain. 
Account Expired Users This option lists user accounts that have expired in 

the domain. 
Locked Out Users This option lists those user accounts which have 

been locked out due to frequent bad login 
attempts. 

Logon Report 
Recently Bad Logged On Users This option, by default, lists those users who 

experience bad logon due to incorrect passwords. 
Report lists users with unsuccessful logins in last 30 
days.* 

Recently Logged On Users This option, by default, lists users who have logged 
on in last thirty days. Report is generated with the 
help of users last logon time.* 

Users Never Logged On This option lists users who have never logged on in 
the domain. 

Terminal Service Report 
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Users Terminal Service Properties This option lists users who have terminal service 
properties. 

Users With Terminal Server Access This option lists users who have access to terminal 
servers. 

 

 

*By default, a report will be generated for a period of thirty days. You can 
customize a report by changing the number of days in Enter the no. of days 
field and clicking Generate, to view a report for the specified number of days. 

 
To view Other User Reports: 
 

1. On Stellar Active Directory Reporting screen, select Other User Reports. 
2. On next screen, under Other User Reports, click on the appropriate option (listed above) 

and the application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
4. To select an attribute / column head, in Column Customization dialog box, select an 

attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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Computer Reports 

Computer Reports option of Stellar Active Directory Reporting module allows you to view different 
kinds of reports on all the domain's computers. 
 
The different computer reports you can view, are as follows: 
 

Report Option Description 
All Computers This option lists all the computers of a domain. 
Domain Controllers This option lists all the domain controllers of the active 

directory. 
OS Based This option lists all the computers which have the same 

operating system installed in them. 
Once you choose this option it will open Operating 
System Version dialog box and will prompt you to 
select an operating system. 

Enable Computers This option will list all the enabled computers of the 
domain. 

Disable Computers This option will list all the disabled computers of the 
domain. 

Inactive Computers This option will list all the inactive computers of the 
domain. 

Managed Computers This option will list all the computers of a domain which 
are managed by an administrator or any other user. 

Unmanaged Computers This option will list all the computers of a domain which 
are not managed by an administrator or any other user. 

Recently Modified Computers This option will list all those computers which have been 
modified in the last thirty days.* 

Recently Created Computers This option will list all computers which have been 
created / added to the active directory in the last thirty 
days.* 

Computer Trusted for 
Delegation 

This option will list all the computers of the domain 
which can perform operations on behalf of servers. 

 

 

By default, a report will be generated for a period of thirty days. You can 
customize a report by changing the number of days in Enter the no. of days 
field and clicking Generate, to view a report for the specified number of days. 

 
To view Computer Reports: 
 

1. On Stellar Active Directory Reporting screen, select Computer Reports. 
2. On next screen, under Computer Reports, click on the appropriate option (listed above) and 

the application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
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4. To select an attribute / column head, in Column Customization dialog box, select an 
attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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Contact Reports 

Contact Reports option of Stellar Active Directory Reporting module allows you to view all active 
directory contacts and emails contacts. 
 
The different contact reports you can view, are as follows: 
 

Report Option Description 
All Contacts This option lists all the contacts of the selected domain 

in an active directory. 
Mail Enabled Contacts This option lists only those contacts which have enabled 

email-ids with them. 
 
To view Contact Reports: 
 

1. On Stellar Active Directory Reporting screen, select Contact Reports. 
2. On next screen, under Contacts Reports, click on the appropriate option (listed above) and 

the application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
4. To select an attribute / column head, in Column Customization dialog box, select an 

attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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Printer Reports 

Printer Reports option of Stellar Active Directory Reporting module allows you to view reports on all 
the domain printers. 
 
The different printer reports you can view, are as follows: 
 

Report Option Description 
All Printers This option lists all the printers attached to the domain. 
Managed Printers This option lists all the printers which are managed using 

administrator. 
UnManaged Printers This option lists all the printers which are attached to the 

domain but are not managed using administrator. 
Recently Created Printers This option, by default, will list all the printers created 

within last 30 days.* 
Recently Modify Printers This option, by default, will list all the printers modified 

within last 30 days.* 
Enable Printer This option will list all the enabled printers of the domain. 
Disable Printer This option will list all the disabled printers of the domain. 
Recently Deleted Printers This option will list all the deleted printers. 

 

 

*By default, a report will be generated for a period of thirty days. You can 
customize a report by changing the number of days in Enter the no. of days 
field and clicking Generate, to view a report for the specified number of days. 

 
To view Printer Reports: 
 

1. On Stellar Active Directory Reporting screen, select Event Log Reports. 
2. On next screen, under Printer Reports, click on the appropriate option (listed above) and the 

application will display the corresponding report. 
3. Once a report is displayed, click on Add Remove Columns to open Column Customization 

dialog box. 
4. To select an attribute / column head, in Column Customization dialog box, select an 

attribute from Available Attribute column and click on Add Columns button. The attribute will 
move to Selected Attributes column. 

5. To remove an attribute / column head, in Column Customization dialog box, select an 
attribute from Selected Attributes column and click on Remove Columns button. The attribute 
will move to Available Attribute column. 

6. Use the Move Up / Move down buttons to move the attributes up or down (to change the order 
of columns). 
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Event Log Reports 

Event Log Reports option of Stellar Active Directory Reporting module, will scan all the events of a 
domain and list them. In other words, you can view all the events performed using Active Directory 
Manager software. 
 
To view Event Log Reports: 
 

1. On Stellar Active Directory Reporting screen, select Event Log Reports. 
2. On next screen, click on Event Log option under Event Log Reports. Active Directory 

Manager will start processing event objects for domains. 
3. Wait for event log processing to complete as it may take some time to complete the 

processing. Application will list all the events that has occurred. 
4. Click Stop to abort event processing at any time. Incase, you abort event processing midway, 

application will display only the processed events. 
5. Number of events will be listed in bottom center of the screen. 
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